1995 Chevy Tahoe No Spark

Tiny
MARVN610
  • MEMBER
  • 1995 CHEVROLET TAHOE
Electrical problem
1995 Chevy Tahoe V8 Four Wheel Drive Automatic

I have a 1995 Chevy Tahoe with about 185,000 miles on it. Recently it started shutting off while driving or sometimes it will not even start. I have changed the distributor cap, rotor, spark plugs, spark plug wires, ignition coil, module control, pickup coil and it still is doing the same thing. Recently it shut off on me and it would not start all. I check there is no spark.
Do you
have the same problem?
Yes
No
Thursday, September 11th, 2008 AT 7:31 AM

7 Replies

Tiny
JACK42
  • MEMBER
Is this a TBI or CPI engine.95 can go either way. Is the check engine light on? If so need to scan it, if it is a CPI it could have a bad crank angle sensor which keeps the PCM from seeing the engine turning.
Was this
answer
helpful?
Yes
No
+1
Thursday, September 11th, 2008 AT 8:10 AM
Tiny
MARVN610
  • MEMBER
The truck is TBI. The Check engine soon lights comes on and turns off. When it stalled and didn't start up again the Check engine light was off.
Was this
answer
helpful?
Yes
No
Thursday, September 11th, 2008 AT 8:16 AM
Tiny
JACK42
  • MEMBER
When it is dead (Wont start) check for power at the coil to see if it getting any.
Was this
answer
helpful?
Yes
No
Thursday, September 11th, 2008 AT 6:45 PM
Tiny
TOSEVSKI79
  • MEMBER
Yep, same problem here down under.

No spark. Now comes the process of long elimination.
Was this
answer
helpful?
Yes
No
-1
Thursday, September 11th, 2008 AT 7:53 PM
Tiny
MARVN610
  • MEMBER
I had my truck get a diagnostic run on it and it came back with the Modular (not sure if that's how it's spelled) in the ECU is NO good. There is no signal coming from it. The guy said it was going to run me approximately $500.00 to get my ECU rebuilt.
Was this
answer
helpful?
Yes
No
-1
Friday, September 12th, 2008 AT 6:22 AM
Tiny
JACK42
  • MEMBER
They do go bad, toss it in his lap, if it doesnt fix it, then he misdiagnosed it and can keep on trying
Was this
answer
helpful?
Yes
No
Friday, September 12th, 2008 AT 7:26 AM
Tiny
TOSEVSKI79
  • MEMBER
Yep same problem, changed crank sensor, distributor, dis. Cap, rotor button, pcm, ignition module, coil, leads, plugs.

Absolutely lost at this stage.
Was this
answer
helpful?
Yes
No
Monday, September 15th, 2008 AT 2:31 AM

Please login or register to post a reply.

Recommended Guides