1997 Chevy Suburban parking lights

Tiny
MIKE31
  • MEMBER
  • 1997 CHEVROLET SUBURBAN
  • V8
  • 4WD
  • AUTOMATIC
  • 97,000 MILES
The paking light fuse blows as soo as I turn on the switch
Do you
have the same problem?
Yes
No
Monday, February 9th, 2009 AT 4:42 PM

5 Replies

Tiny
BOWTIE BABY
  • MEMBER
You most likely have a wire grounding out some where in the system. Check to make sure you have the correct fuse in the correct spots and check the relay. Trace wiring to look for bare wires, wires that have melted together, etc. If you have a towing kit on it check the wiring for that also.
Was this
answer
helpful?
Yes
No
Tuesday, February 10th, 2009 AT 4:03 AM
Tiny
TNMAMA
  • MEMBER
I am having the same issue. I keep replacing the 20amp fuse #9, and it keeps blowing. I lose the dash lights, running lights, and trailer lights.
I'm going to start checking the wires tomorrow - Will let you know if I find anything.
Was this
answer
helpful?
Yes
No
Friday, February 20th, 2009 AT 11:34 PM
Tiny
MIKE31
  • MEMBER
I have found the problem and it was in the power mirrors thanx hope you are able to find your problem it all runs through the switch on the driver side door
Was this
answer
helpful?
Yes
No
Saturday, February 21st, 2009 AT 5:59 PM
Tiny
TNMAMA
  • MEMBER
I found a tiny section of exposed wire behind the passenger side parking lamp. It appears as though it was hitting metal and shorting out. I have covered the wire with electrical tape, and the fuse has not blown since.
Thanks All!
Was this
answer
helpful?
Yes
No
Tuesday, February 24th, 2009 AT 5:29 AM
Tiny
BOWTIE BABY
  • MEMBER
Good, glad to help, all of your votes and feedback are appreciated.
Was this
answer
helpful?
Yes
No
Tuesday, February 24th, 2009 AT 5:00 PM

Please login or register to post a reply.

Recommended Guides