Silverado windshield wiper problem

Tiny
VETTEMAN2003
  • CHEVROLET SILVERADO

2002 Chevrolet Silverado, 45,000 miles, V-6 engine. When the problem began, the variable speed would work for a while, then the wipers would just stop. High speed would still work. After a while the wipers would work again. Now, the variable speed does not work at all and the wipers will not park. They only work on high. Any idea what could cause this?

Do you
have the same problem?
Yes
No
Sunday, May 27th, 2007 AT 5:57 PM

3 Replies

Tiny
JIMC4741
  • MEMBER

Have a 98 with similar problems. It was caused by the connector plug to the drivers side wiper motor. When they go out wiggle the connector plug to see if they come back on. I ended up having connector plug replaced.

Was this
answer
helpful?
Yes
No
+1
Saturday, June 2nd, 2007 AT 8:55 AM
Tiny
CARPENTER
  • MEMBER

There is a windshield wiper module within the motor. It is a simple allen wrench repair. There are three small allens and the board comes out with the female plug end attached. Slide the new one in and you are done.

Was this
answer
helpful?
Yes
No
Wednesday, June 6th, 2007 AT 9:44 PM
Tiny
VETTEMAN2003
  • MEMBER

Thanks for your replies. Apparently on my 2002 Silverado, the control board is built into the plastic cover. When I removed the cover I saw no way to remove the board. I just today replaced the entire motor assembly, I got the whole thing on EBAY for the price of the cover alone. I am happy to say I have all speeds working now and all seems well. Sadly, as I was doing the work, I remembered I need a tune up, and can't even see the distributor cap, looks like major surgery just to replace the cap, don't ya just love these new vehicles. Thanks again, I really like this forum.

Was this
answer
helpful?
Yes
No
Sunday, June 10th, 2007 AT 8:18 PM

Please login or register to post a reply.

Other Windshield Wiper Speed Questions