2001 Chevy Silverado anti-lock brakes?

Tiny
FRIARTUT
  • MEMBER
  • 2001 CHEVROLET SILVERADO
  • V8
  • 4WD
  • AUTOMATIC
  • 70,000 MILES
Occasionally when I apply the brakes, if feels like the anti-lock is kicking in. This is happening on dry pavement.
Do you
have the same problem?
Yes
No
Sunday, October 18th, 2009 AT 7:14 AM

9 Replies

Tiny
MERLIN2021
  • EXPERT
If the ABS light is off, are you turning the wheel as this happens? If yes, check hub/wheel bearings for play.
Was this
answer
helpful?
Yes
No
-2
Sunday, October 18th, 2009 AT 7:46 AM
Tiny
QUAGMIRE86
  • MEMBER
I had the same issue with my 2000 3/4 ton. The problem was that the ABS sensor, which is located at each front wheel bearing assembly (only one side caused the problem) was going "Out of range" due to corrosion. It was a simple fix (ie no money). What happened/happens is that the ABS sensor (which is a magnet in a plastic housing), the item is bolted to the wheel bearing housing, and if you live in an area that uses salt on the roads will cause corrosion. Rust will begin to form on the top of the wheel bearing (between the housing and the sensor). That little bit of rust will push the sensor up and the magnet will not read the toothed ring gear inside the wheel bearing housing. There is one bolt (8mm I think) that retains the sensor, take it off and carefully twist and pull the sensor straight up out of the housing. When it is out, put a cotton ball in the hole and use a knife or other instrument to scrape the rust off the housing (the cotton ball is to keep the rust from falling in the open hole of the wheel bearing). Once you get the big chunks of rust off, use a wire brush to clean the area real well. Put a film of grease on the outside of the sensor (that goes into the hole), take the cotton ball out and re-insert the sensor back into the hole. Affix the retaing bolt and (after you put the wheel back on) take it for a test ride. You will say."Holy monkey-butt, that was easy and cheap". It worked for me.
Was this
answer
helpful?
Yes
No
+2
Sunday, October 18th, 2009 AT 8:12 AM
Tiny
FRIARTUT
  • MEMBER
The light is off, and it happens when the wheels are straight.
Was this
answer
helpful?
Yes
No
+2
Sunday, October 18th, 2009 AT 4:18 PM
Tiny
FRIARTUT
  • MEMBER
Thanks. I'll give that a try.
Was this
answer
helpful?
Yes
No
Sunday, October 18th, 2009 AT 4:19 PM
Tiny
QUAGMIRE86
  • MEMBER
Let us know how you made out with the repair.
Was this
answer
helpful?
Yes
No
Monday, October 19th, 2009 AT 8:19 AM
Tiny
FRIARTUT
  • MEMBER
Well it did work, but now the abs light is on. Any suggestions? It was a little harder than I expected, the dirt road I live on is hell on brakes. I had to heat the calipers to break the bolts loose.
Was this
answer
helpful?
Yes
No
Saturday, October 24th, 2009 AT 2:57 PM
Tiny
MERLIN2021
  • EXPERT
Well. Using a torch on calipers is not a good idea. Seal may be leaking, is the red brake light on?
And if you followed the other guys advice, you may have damaged the sensor, grab an OHM meter, unplug the sensor from the harness and take a reading, I think yours should be about 2300 ohms, but I'll see if I can find the spec.
Was this
answer
helpful?
Yes
No
Monday, October 26th, 2009 AT 6:50 PM
Tiny
QUAGMIRE86
  • MEMBER
Can you put it on a code reader and find out what code it is showing? It may be a short or open code on the sensor (may be the plastic housing got cracked during procedure). I feel silly asking, but you did re-connect the ABS sensor back into the wiring harness right? (Assuming you disconnected it at any time during your previous maintenance). I'm at work right now and can't give you the restistance reading on my sensor.

Oh, and I agree with merlin2021. Heating a caliper is scetchy at best. In my younger days, I did that and ended up exploding the re-inforced rubber line that attaches to the caliper. Yeah. My head was in the wheel well when it happened. Very, very loud (ouch). :
Was this
answer
helpful?
Yes
No
Monday, October 26th, 2009 AT 10:51 PM
Tiny
MERLIN2021
  • EXPERT
Here's the scoop on whell speed sensors:
DTC C0221, DTC C0222, DTC C0223, DTC C0224, DTC C0225, DTC C0226, DTC C0227: WHEEL SPEED SENSOR CIRCUIT MALFUNCTION 1. Perform diagnostic system check. See DIAGNOSTIC SYSTEM CHECK under DIAGNOSIS & TESTING. After performing diagnostic system check, go to next step. 2. Install scan tool. Turn ignition on. Drive vehicle at speeds greater than 20 MPH. Recheck DTCs. If DTC resets, go to next step. If DTC does not reset, problem is intermittent. 3. Raise and support vehicle. Disconnect wheel speed sensor harness connector. Using a DVOM, check resistance of wheel speed sensor. If resistance is 700-2000 ohms, go to next step. If resistance is not 700-2000 ohms, go to step 8. 4. Manually spin wheel as fast as possible. Using a DVOM, measure AC voltage generated by sensor as wheel spins. If voltage reading is greater than 100 mV, go to next step. If voltage reading is not greater than 100 mV, go to step 8. 5. Check for poor connections at wheel speed sensor harness connector. Repair as necessary. After repairs, go to step 10. If connections are okay, go to next step. 6. Disconnect wheel speed sensor harness connector. Check circuit for open, short to ground, short to voltage or shorted together. Repair as necessary. After repairs, go to step 10. If circuit is okay, go to next step. 7. Check for poor connections at EBCM harness connector. Repair as necessary. After repairs, go to step 10. If connections are okay, go to step 9. 8. Replace wheel speed sensor. After replacing sensor, go to step 10. 9. Replace EBCM. After replacing EBCM, go to next step. 10. Using scan tool, clear DTCs. Operate vehicle at speeds greater than 20 MPH. Recheck DTCs. If DTC resets, go to step 3. If DTC does not reset, system is okay.
Was this
answer
helpful?
Yes
No
Tuesday, October 27th, 2009 AT 11:02 AM

Please login or register to post a reply.

Recommended Guides