No injector Pulse

Tiny
TOPFUEL
  • MEMBER
  • 1993 CHEVROLET SILVERADO
Electrical problem V8 Two Wheel Drive Automatic 216k miles

Hi, yesterday my truck would not start. I am getting spark, but no fuel is spraying from the injectors. I removed the fuel line feeding the TBI to check and see if fuel was reaching it, and it is. Not a lot of pressure but it is getting fuel. The TBI is a brand new Holley 670cfm that was working flawlessly up until the no start. The engine has been rebuilt but no problems to speak of until this. Fuel pump is the original so maybe its time to be replaced? Checked the fuses I could find in my diagram and they are all good, wiring looks sound going to the TBI and injectors. Just don't know why the injectors aren't spraying any fuel after trying to start multiple times.

Thanks in advance!
Do you
have the same problem?
Yes
No
Friday, November 28th, 2008 AT 2:51 PM

9 Replies

Tiny
RASMATAZ
  • MEMBER
What you need to do here is check the actual fuel pressure with a fuel pressure gauge designed for your fuel system

Here is a guide

https://www.2carpros.com/articles/how-to-check-fuel-system-pressure-and-regulator

if okay-check for power to the injector/s-got power still no pulses-could mean the computer ground drivers has gone bad

Here is a guide

https://www.2carpros.com/articles/how-to-test-a-fuel-injector

Check out the diagrams (Below)

Please let us know what happens.

Cheers
Was this
answer
helpful?
Yes
No
+2
Friday, November 28th, 2008 AT 3:00 PM
Tiny
TOPFUEL
  • MEMBER
Checked fuel pressure to TBI, its sitting at 13 There is power going to the injectors, what else would cause this problem?


http://www.2carpros.com/forum/automotive_pictures/278243_IMG_0920_1.jpg



http://www.2carpros.com/forum/automotive_pictures/278243_IMG_0919_1.jpg

psi.
Was this
answer
helpful?
Yes
No
+2
Friday, November 28th, 2008 AT 6:07 PM
Tiny
TOPFUEL
  • MEMBER
New thought, I recently had a car security system installed, could this have somehow caused a problem so suddenly a week after installation?
Was this
answer
helpful?
Yes
No
Friday, November 28th, 2008 AT 6:10 PM
Tiny
RASMATAZ
  • MEMBER
If it has to do w/the security system it won't last a week. Hook up a noid light to the injector and see what happens-if its not blinking its not pulsing could be the computer ground drivers -or the computer is missing an ignition reference signal from the cam/crankshaft sensors therefore not synchronizing the injectors.
Was this
answer
helpful?
Yes
No
Friday, November 28th, 2008 AT 6:16 PM
Tiny
TOPFUEL
  • MEMBER
I don't have a noid light and its a too late to buy one today, but I threw a voltage meter on it and only saw constant current when the motor was cranking, no pulsing, then again the meter probably isn't fast enough to see the pulses. I guess i'll pick one up tomorrow. Thanks much for the help so far!
Was this
answer
helpful?
Yes
No
+1
Friday, November 28th, 2008 AT 6:45 PM
Tiny
TOPFUEL
  • MEMBER
Hi again, tested injectors with a light and its not blinking at all on either injector. Checked for codes and its showing code 12 (No Problems detected). So I replaced the ECM and the truck started it was bad. Thanks for your help
Was this
answer
helpful?
Yes
No
Saturday, November 29th, 2008 AT 4:33 PM
Tiny
BARFARMER
  • MEMBER
I have a 1993 Silverado that has don that more than once. In each case it was the Distributor. I bought a dist at Auto Zone with a lifetime warantee and they have to replace it about every 2Yr. You will think it is a fuel system problem but it is not. I have had this problem on another 1993 chevy custom with a 350 engine 2 times and my own at least 4 times hope this helps.
Keeps AAA in the Rollback business too ha ha
Was this
answer
helpful?
Yes
No
Sunday, January 23rd, 2011 AT 7:21 AM
Tiny
RASMATAZ
  • MEMBER
Test the pick-up coil in the distributor that's the one that synchronizes the injectors
Was this
answer
helpful?
Yes
No
+2
Thursday, February 3rd, 2011 AT 6:10 PM
Tiny
BGOERMAR80
  • MEMBER
I have a 93 Chevy Cheyenne 1500 4.3l v6 tbi about a
month ago I was driving down the road and my truck just
died I pulled over looked under the hood realized one of
my injectors wasn't fireing off so went to autozone got 2
new injectors still nothing so I got it home from a buddy
with a trailer I replaced the distributor and was able to
drive it it drove fine for about a day then I took it on the
highway and it started to loose power by the time I got to
work couldn't go over 35 mph so tried timing it and
nothing when the truck is idling it surges up and down
and it will barely move now please help
Was this
answer
helpful?
Yes
No
+6
Monday, December 28th, 2015 AT 7:24 PM

Please login or register to post a reply.

Recommended Guides