1998 Chevy S-10 Blazer wont start after the rain

Tiny
98S10BLAZER
  • MEMBER
  • 1998 CHEVROLET S-10
Engine Mechanical problem
1998 Chevy S-10 6 cyl Two Wheel Drive Automatic 171k miles

Noticed my blaser hard to start during or after the rain. Now it doesnt start after this wknds rain Sat. Trys toTurn over but no "coughing" at all. Sounds like no gas or spark. 2wks ago error code said MAF sensor. I replaced that and disconnected battery. Still wont start. I smell gas after trying to turn it over and hear fuel pump. Removed sparkplug cable from plug in engine. Bought a spark plug and plugged it into cable and tried to start the car. Had spark when I put it close to the engine. Noticed a little corrosion so I cleaned out distrib and rotor. Still wont start. So I smell gas and got spark. Maybe a sensor somewhere not working?
Any suggestions before Im forced to call a tow truck for the shop?
Do you
have the same problem?
Yes
No
Monday, September 15th, 2008 AT 2:51 PM

6 Replies

Tiny
RASMATAZ
  • MEMBER
You got a snapping blue spark and smell fuel-lets do a fuel pressure check to rule out the fuel pump and also check for injection pulses from the injector/s.

Or try this below and tell me what happened

Get a carb cleaner and spray into the carb or the throttle body on an EFI. Did it start and die? If not disconnect a sparkplug wire or 2 and ground it to the engine -have helper crank engine over-do you have a snapping blue spark? If so-you have a fuel problem, check the fuel pressure to rule out the fuel pump/pressure regulator and listen to the injector/s are they pulsing or hook up a noid light. No snapping blue spark continue to troubleshoot the ignition system-power input to the coil/coil, distributor pick-up coil, ignition control module, cam and crank sensors-
Was this
answer
helpful?
Yes
No
Monday, September 15th, 2008 AT 3:08 PM
Tiny
98S10BLAZER
  • MEMBER
I used starting fluid in thottlebody with and without boot on. The blazer just sputtered tried to kick over jerking and backfiring briefly through the thottlebody and stopped. Could it be a possible egr valve stuck open? Spark was blue gas pressure was 58 to 60 psi on the rail. Good spark and gas pressure. Or could I check something else out?
Was this
answer
helpful?
Yes
No
Monday, September 15th, 2008 AT 8:59 PM
Tiny
98S10BLAZER
  • MEMBER
Can someone please reply to my question. Blazer has not started in 4 days. From previous posts looks like possible issues for not starting are coil, cap/rotor, egr sensor, crank sensor. Cap has some white stuff on metal pins. Cleaned that out and metal piece on top of rotor. Put back on and still wont start. Good spark and gas pressure. Starting fluid in Throttle body with and without boot on just sputters and jerks car around. Backfire through throttle body to. How do you check coil. Could egr be the problem? Was going to locate that somewhere on engine and remove it. Put hand over hole to seal it. Heard egr could stick open and you would have no "vacuum".
What should I try next? Gas pressure at rail 60 to 58psi is that good?
Was this
answer
helpful?
Yes
No
Tuesday, September 16th, 2008 AT 1:11 PM
Tiny
RASMATAZ
  • MEMBER
How do you check coil. You said spark was blue then it should fire up when you hit it with the starting fluid. Are you spraying behind the throttle plate?

The EGR valve is electronic in from of the lower intake plenum.
Was this
answer
helpful?
Yes
No
Tuesday, September 16th, 2008 AT 2:03 PM
Tiny
98S10BLAZER
  • MEMBER
Yes just like a carb. Open the flap and squirt the starting fluid inside past the flap. I counted to 3sec. Tried to start with and without boot. Then I squirted to 5sec. And did the same. Blazer just sputtered and backfired through throttle body. Seemed like engine was only burning the starting fluid. The blazer sputtered longer when I pushed peddle down halfway and to floor. If I kept foot off of gas pedal only a few sputters.
Blue spark good gas pressure. Any other suggestions?
What does do? Is it possible the egr is causing a problem? I heard a MAS sensor could be a problem to. To many guesses. Trying to figure out hoe to troubleshoot what when for this issue.
Was this
answer
helpful?
Yes
No
Tuesday, September 16th, 2008 AT 2:37 PM
Tiny
RASMATAZ
  • MEMBER
Blue spark good gas pressure. Any other suggestions?

When you hit it with carb cleaner-does it combust for 1sec-if it combust try checking the ignition timing. When push comes to shove open up the upper plenum and investigate the spider unit that's if its a Vortec
Was this
answer
helpful?
Yes
No
Tuesday, September 16th, 2008 AT 4:38 PM

Please login or register to post a reply.

Recommended Guides