2007 Chevy Impala programming remote entry system

Tiny
JERRYALDZ
  • MEMBER
  • 2007 CHEVROLET IMPALA
Computer problem
2007 Chevy Impala Two Wheel Drive Automatic

I just bought a 2007 Impala. One of the key fobss work - the other does not! I checked the battery in the non-functioning fob and it is OK?
The dealer wants $134 for a new fob + $ 46 to program it.

I found a new OEM fob on ebay for $30
It came with instructions to program it. I mentions to press the vehicle information system button until it reads " to relearn remote key" is displayed.

HOW DO I ENTER THIS MODE?

It then mentions pressing the set/reset button. And will display "remote ket learning active"

Will this reset the working key fob as well?
Will I have to re-program both fobs?
Do you
have the same problem?
Yes
No
Monday, September 21st, 2009 AT 12:00 PM

3 Replies

Tiny
BRIAN 1
  • EXPERT
Follow this info, Remote Key
To access this display, the vehicle must be in PARK (P). This display allows you to match the Remote Keyless Entry (RKE) transmitter to your vehicle. To match an RKE transmitter to your vehicle, do the following:

Press the vehicle information button until PRESS TO RELEARN REMOTE KEY displays.
Press the set/reset button.
The message REMOTE KEY LEARNING ACTIVE will display.

Press and hold the lock and unlock buttons on the first transmitter at the same time for about 15 seconds.
A chime will sound indicating that the transmitter is matched.

To match additional transmitters at this time, repeat Step 3.
Each vehicle can have a maximum of eight transmitters matched to it.

To exit the programming mode, you must cycle the key to OFF. All this info is outlined in your car manual.
Was this
answer
helpful?
Yes
No
Monday, September 21st, 2009 AT 5:37 PM
Tiny
LAKER400
  • MEMBER
Brian or anyone. Everything above worked for the first transmitter then I programmed the 2nd transmitter as instructed above. Each transmitter would start the car once but not twice. They both would still lock and unlock the doors.I would repeat the steps to program both but only use one Remote and it continues to work correctly, and the 2nd will still lock and unlock doors until its used to start car which causes both to stop starting the car again. What do you think is going on?
Was this
answer
helpful?
Yes
No
Saturday, July 14th, 2012 AT 1:21 AM
Tiny
RIVERMIKERAT
  • MEMBER
It sounds as though the code randomizer is malfunctioning. See if you can take it to a shop and have it scanned for all SOFT codes. These are codes that don't set an error message or turn on the CEL light.
Was this
answer
helpful?
Yes
No
Saturday, July 28th, 2012 AT 5:05 PM

Please login or register to post a reply.

Recommended Guides