Weird noise from left turn signal

Tiny
SEVEPPA
  • MEMBER
  • 1998 CHEVROLET CAVALIER
Electrical problem 4 cyl Wheel Drive Type unknown Automatic 80k miles

For a couple of weeks my left turn arrow would come on whenever I turned on the lights and when I would use the signal, it would blink more rapidly then normal but it was still working. Yesterday, while waiting at a light to turn left with the signal on, it began making a weird noise, like a grinding hum. The signal doesn't work at all. The noise occurs whenever I use the left turn signal, not at all when I use the right. AND, the noise is not there when I have the lights turned on; the signal still doesn't work but the noise goes away when I turn on the lights. Where should I start with this? I am totally clueless!
Do you
have the same problem?
Yes
No
Monday, December 10th, 2007 AT 9:54 AM

2 Replies

Tiny
STEVEPOWELL81
  • MEMBER
You need to have your bulbs in the rear checked and replaced. When it blinks fast, that means a bulb on that side is blown out. I could explain the rest, but it is just easier to let you know that you have a blown out bulb(s) on whichever side is flashing fast. Have someone check all the bulbs with you and replace the bad one(s).
Was this
answer
helpful?
Yes
No
-2
Thursday, December 20th, 2007 AT 7:43 AM
Tiny
KEN
  • ADMIN
Hello,

It sounds like you have a turn signal/hazard flasher that has gone out. I would start by replacing it here is its location.

Check out the diagrams (Below)

Please let us know if you need anything else to get the problem fixed.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Sunday, January 21st, 2018 AT 2:21 PM

Please login or register to post a reply.

Recommended Guides