Car will not start after disconnecting battery

Tiny
MLENNI
  • MEMBER
  • 2007 CHEVROLET EQUINOX
  • 3.4L
  • 6 CYL
  • AUTOMATIC
  • 126,988 MILES
When I started the car today the radio would not turn on at all, but the car started so we disconnected the battery and reconnected and the key got stuck! The radio, lights, everything worked, but the windows and locks did not work and car would not turn over at all. I am not sure what to do or where to start.
Do you
have the same problem?
Yes
No
Sunday, January 29th, 2017 AT 10:37 PM

11 Replies

Tiny
SATURNTECH9
  • EXPERT
The key was not on when you disconnected the battery and hooked it back up? Did you try to jump start it? Also, has the battery been charged and tested? Are the battery cables clean and tight?
Was this
answer
helpful?
Yes
No
Monday, January 30th, 2017 AT 6:21 AM
Tiny
MLENNI
  • MEMBER
Battery was charged overnight. Key was not on and we tried to jump start it last night.
Was this
answer
helpful?
Yes
No
Monday, January 30th, 2017 AT 6:16 PM
Tiny
SATURNTECH9
  • EXPERT
Does the engine crank normally and not start?Also the security light isn't on solid or flashing with the key in the run position?
Was this
answer
helpful?
Yes
No
-1
Tuesday, January 31st, 2017 AT 7:20 AM
Tiny
SATURNTECH9
  • EXPERT
Also why was the battery disconnected to begin with?
Was this
answer
helpful?
Yes
No
Tuesday, January 31st, 2017 AT 7:21 AM
Tiny
MLENNI
  • MEMBER
The radio wouldn't work so we disconnected the battery. The car won't turn over at all and the screen reads service vehicle soon. There's no security light on. Windows and locks don't work either
Was this
answer
helpful?
Yes
No
Tuesday, January 31st, 2017 AT 9:03 AM
Tiny
MLENNI
  • MEMBER
And the key is stuck in the ignition
Was this
answer
helpful?
Yes
No
Tuesday, January 31st, 2017 AT 9:06 AM
Tiny
SATURNTECH9
  • EXPERT
You should have tried pulling all the radio fuses for ten minutes that's what your supposed to try I know you didn't know have you checked all the fuses yet?
Was this
answer
helpful?
Yes
No
Tuesday, January 31st, 2017 AT 10:03 AM
Tiny
MLENNI
  • MEMBER
We we tested all of them they are all good and the relays are good too
Was this
answer
helpful?
Yes
No
Tuesday, January 31st, 2017 AT 10:19 AM
Tiny
KEN
  • ADMIN
It really sounds like the battery is having a problem. Can you test it by following this guide please.

https://www.2carpros.com/articles/car-battery-load-test

Please let us know what happens so it will help others

Best, Ken
Was this
answer
helpful?
Yes
No
Monday, February 6th, 2017 AT 1:34 AM
Tiny
MLENNI
  • MEMBER
Thank you for your reply. We tested battery it's still good. Car reads Service vehicle soon, service air bags soon, service tire monitor system soon. Maybe body control module?
Was this
answer
helpful?
Yes
No
Monday, February 6th, 2017 AT 11:11 AM
Tiny
STEVE W.
  • EXPERT
Try this. Disconnect the battery. Connect the two battery cables together to drain the capacitors in the system and clear any learned behavior. Reconnect the cables and see if anything has changed.
Was this
answer
helpful?
Yes
No
Wednesday, February 8th, 2017 AT 1:43 PM

Please login or register to post a reply.

Recommended Guides