Car will not start

Tiny
JAKEM710
  • MEMBER
  • 1994 NISSAN ALTIMA
  • 2.5L
  • 4 CYL
  • 2WD
  • MANUAL
  • 210,000 MILES
About four months ago I blew my head gasket after having late diagnosed water pump issues. Replaced pump, fixed head gasket. I say this as a reference as to what my problem is and maybe it came from it.

Now my car will not start 70% of the time, or it will shut off two seconds after starting. I drove it to work today and I had to leave it there because it wouldn't start. I have replaced plugs, plug wires, fuel filter, throttle position sensor, and every fuse.

So I guess my question is, what else could it be? Possibly bad TPS unit? Or maybe ignition switch? Thanks for any help, this is driving me crazy!
Do you
have the same problem?
Yes
No
Monday, August 5th, 2019 AT 8:55 PM

3 Replies

Tiny
SCWICKEDSTANG
  • EXPERT
Hello,

Is the security light blinking? In the diagrams down below I have included the wiring diagrams for your vehicle's starting system for reference right now. Please get back to us with the security light answer for now.

Thanks,
Alex
2CarPros
Was this
answer
helpful?
Yes
No
Tuesday, August 6th, 2019 AT 5:49 AM
Tiny
JAKEM710
  • MEMBER
Not that I am aware of. I don't think it has a security light because there isn't an anti theft system in it.
Was this
answer
helpful?
Yes
No
Tuesday, August 6th, 2019 AT 6:14 AM
Tiny
SCWICKEDSTANG
  • EXPERT
Hello again,

Okay, can you please inspect Ground #206 which is located in the center of Instrument Panel. In the diagrams down below I have included a guide for how to properly inspect grounds. Please get back to us with what you are able to find out.

Thanks,
Alex
2CarPros
Was this
answer
helpful?
Yes
No
Tuesday, August 6th, 2019 AT 6:42 AM

Please login or register to post a reply.

Recommended Guides