Car idles fine but will not accelerate

Tiny
BEALLGWV
  • MEMBER
  • 1999 HONDA ACCORD
  • 244,000 MILES
I was driving and the car has been acting weird. The first thing I noticed is when I would push the gas pedal hard it bogs down which reminded me of when I had a crack in the rubber air intake hose. Drove some more after getting gas went about 10 miles and it lost all power and stalled luckily its a manual so I got over to the side of the road safely. My mechanic replaced the EGR valve and now it starts but the engine bogs down a little before 2000 RPMS. My mechanic said it may have jumped time but unsure. The timing belt won't need replacing for another 35,000; the cap and rotor spark plugs and wires have been replaced a month ago. Replaced Coolant hose recently. Used seafoam to clean out the carbon because it was having problems for about a month with running. It would run fine just idle kind of low and not perform properly. Any ideas or suggestions? I have looked and seen people suggest fuel pressure and dirty intake manifolds, would that cause the engine to die so suddenly? It performed great and literally overnight the engine started having issues. I have sprayed with carb cleaner all the vacuum hoses and there are no leaks. HELP PLEASE :D
Do you
have the same problem?
Yes
No
Friday, July 12th, 2013 AT 10:12 PM

1 Reply

Tiny
HMAC300
  • EXPERT
Scan for codes and check fuel pressure first
Was this
answer
helpful?
Yes
No
Saturday, July 13th, 2013 AT 5:59 AM

Please login or register to post a reply.

Recommended Guides