Shuts off while driving

Tiny
EDWARD F. VENN JR
  • MEMBER
  • 2005 BUICK LA CROSSE
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 100,785 MILES
Engine shuts off while driving, pull over and stop, crank a couple of times and starts, runs for undetermined amount of time before it happens again.
Do you
have the same problem?
Yes
No
Sunday, February 28th, 2010 AT 4:08 PM

18 Replies

Tiny
KEN
  • ADMIN
This sounds like a fuel pump is starting to fail causing the engine to stall here is a guide to confirm, please follow it and get back to me.

https://www.2carpros.com/articles/how-to-check-fuel-system-pressure-and-regulator

Please let us know what you find. We are interested to see what it is.

Cheers, Ken

Was this
answer
helpful?
Yes
No
Sunday, February 4th, 2018 AT 2:34 PM
Tiny
EDWARD F. VENN JR
  • MEMBER
Thanks for the guide I checked the fuel pressure when the engine stalled and there was none then I checked for power at the pump wire and it had it what do I do now?
Was this
answer
helpful?
Yes
No
-1
Sunday, February 4th, 2018 AT 2:35 PM
Tiny
KEN
  • ADMIN
Yep, the pump has gone bad here is a guide to help you see what you are in for when doing the job.

https://www.2carpros.com/articles/how-to-replace-an-electric-fuel-pump

Check out the diagrams (Below)

Please let us know what happens.

Cheers, Ken
Was this
answer
helpful?
Yes
No
-1
Sunday, February 4th, 2018 AT 2:37 PM
Tiny
EDWARD F. VENN JR
  • MEMBER
Wow great job I pulled the pump and got a new one from Amazon and the car runs again, thanks for your help this site is great.
Was this
answer
helpful?
Yes
No
-1
Sunday, February 4th, 2018 AT 2:37 PM
Tiny
MR.CHIPS
  • MEMBER
  • 2005 BUICK LA CROSSE
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 30,000 MILES
Engine Mechanical problem
2005 Buick La Crosse 6 cyl Front Wheel Drive Automatic 30,000 miles

At highway speeds and at low speeds, the engine stops running with no warning. STARTING DISABLED warning message shows up on driver information center. The car was hooked up to a computer at a dealer and nothing was found wrong. We tried fixing the problem after we found a TSB 05-06-04-037 which recommended cleaning the negative battery cable. This did not solve the problem.
Was this
answer
helpful?
Yes
No
Sunday, February 4th, 2018 AT 2:39 PM (Merged)
Tiny
BRIAN 1
  • MEMBER
Looking at the bulletin you have you only performed half the bulletin, cleaning the negative terminal was only part of the fix, but the other half is the PCM has to be updated with the latest calibration to address a stalling condition. And I've read the bulletin is does not say to clean the neg cable at the battery is states to clean the negative ground that attaches to the body. Clean the neg ground and reflash the PCM and this problem will go away.I'm suprised the dealer didn't look at this bulletin. Post back with any other questions.
Was this
answer
helpful?
Yes
No
+1
Sunday, February 4th, 2018 AT 2:39 PM (Merged)
Tiny
MR.CHIPS
  • MEMBER
Thank you for the reply.I will take it to a dealer(prob lem is I am in Mexico so I hope they get the same PSB)On another forum, someone suggested that fuse#15 might need to be replaced. Fuse somehow loses connection after car is warm. Any thoughts?
Was this
answer
helpful?
Yes
No
Sunday, February 4th, 2018 AT 2:39 PM (Merged)
Tiny
MR.CHIPS
  • MEMBER
Forgot to add that we did clean the connection at the frame rail.
Was this
answer
helpful?
Yes
No
Sunday, February 4th, 2018 AT 2:39 PM (Merged)
Tiny
BRIAN 1
  • MEMBER
I"ve never heard or seen a bulletin for the #15 fuse needing to be replaced, I think somebody was misinformed. Post back with any other questions.
Was this
answer
helpful?
Yes
No
-1
Sunday, February 4th, 2018 AT 2:39 PM (Merged)
Tiny
4RUBY
  • MEMBER
  • 2005 BUICK LA CROSSE
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 50,000 MILES
Engine Performance problem
2005 Buick La Crosse 6 cyl Two Wheel Drive Automatic 50,000 miles

Engine stalls after running a few minutes. Normally car will start after waiting 2 - 3 minutes. Today car totally shut down while driving.
Was this
answer
helpful?
Yes
No
Sunday, February 4th, 2018 AT 2:39 PM (Merged)
Tiny
MR.CHIPS
  • MEMBER
Thanks for the reply.I am in Mexico and language will be a problem. Is reflashing the PCM a common occurrence? Anything, I should try to make clear?Would the TSB number be the same regardless of whether it was the U.S, Canada, or Mexico.
Was this
answer
helpful?
Yes
No
Sunday, February 4th, 2018 AT 2:40 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
If it doesn't start at all now, have you checked for spark and fuel to the engine? Has the check engine light come on?

Let me know.
Joe
Was this
answer
helpful?
Yes
No
+2
Sunday, February 4th, 2018 AT 2:40 PM (Merged)
Tiny
BRIAN 1
  • MEMBER
As far as refashing the pcm, it's not a common problem but it is a common thing. If there is a problem with different aspects of the vehicle GM will come up with software to correct a problem, it's more of a calibration for the car, thats why there are software updates. Just tell them you found a bulletin outlining your problem and you fixed the ground but need the pcm reflashed. The tsb number will be the same nomatter what country your in. Some other in for I came across is this tsb:Vehicle may crank and not start or may not stay running intermittently.

Recommendation/Instructions:
Cause:
The 4 bolts that hold the underhood bussed electrical center (UBEC) may become loose, causing a poor connection at the back of the UBEC.

Correction:
Tighten the 4 bolts that hold the UBEC to the inner fenderwell.

If you go to the dealer they have access to these bulletins.
Was this
answer
helpful?
Yes
No
+1
Sunday, February 4th, 2018 AT 2:40 PM (Merged)
Tiny
MR.CHIPS
  • MEMBER
Thanks for the answers. Took vehicle back to the dealership. They did exactly what you suggested and vehicle no longer stops running thanks
Was this
answer
helpful?
Yes
No
Sunday, February 4th, 2018 AT 2:40 PM (Merged)
Tiny
DOREEN CALVE
  • MEMBER
  • 2005 BUICK LA CROSSE
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 34,000 MILES
Engine Performance problem
2005 Buick La Crosse 6 cyl Front Wheel Drive Automatic 34000 miles

the problem doesn't happen all the time.
I'll be driving on the highway then it feels like it isn't getting fuel, starts to stutter like it's going to die out, then runs okay. The bad thin is when you have cars behind you, I am affraid of getting rear ended when this happens
Was this
answer
helpful?
Yes
No
Sunday, February 4th, 2018 AT 2:40 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi:
First I suggest that you take the car to a nationally recognized parts store to have the computer scanned. Many things could cause this type of problem. If you get a code, we'll know what direction to move. Most of these parts stores will scan it for free, so it's nothing out of your pocket.

If you get no codes, let me know and we'll try to figure this out.

Joe
Was this
answer
helpful?
Yes
No
Sunday, February 4th, 2018 AT 2:40 PM (Merged)
Tiny
BRO2YORK
  • MEMBER
  • 2005 BUICK LA CROSSE
Engine Performance problem
2005 Buick La Crosse 6 cyl Front Wheel Drive Automatic

when I start my buick lacrosse I notice that the RPM needle is rev low, like its about cut off. I use engine restore and fuel injector clean my car is at 85,000 miles should I get a tune up because I talk to people at auto stores and they told me that theres not a replacment part for the fuel fliter?
Was this
answer
helpful?
Yes
No
Sunday, February 4th, 2018 AT 2:40 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
Has the check engine light ever come on? Honestly, if the fuel pump pressure is too low, the engine would be doing more than just idleing low. You can check fuel pump pressure. Let me know if you need directios. Also, try cleaning the mass air flow sensor (MAF). There is a specific cleaner for them.
Was this
answer
helpful?
Yes
No
Sunday, February 4th, 2018 AT 2:40 PM (Merged)

Please login or register to post a reply.

Recommended Guides