CAR WON'T START

2005 Buick La Crosse

Tiny

Wahoo73

June, 21, 2010 AT 8:47 AM

Engine Mechanical problem
2005 Buick La Crosse 6 cyl Two Wheel Drive Automatic 107, 00 miles

My wife's LaCrosse wouldn't start this morning. We drove it yesterday with no issues or indications of any starter or ignition issues. The battery seems fine, as lights, warning bells, radio, etc. Are all functioning. When we turn the key in the ignition all we get is a rapid clicking sound. Is this likely a starter/solenoid problem? An ignition problem? Both? Are there any " tricks" I can use to get the car started to drive to a repair shop? What should I expect cost of a repair to be?
Thanks for your advice and assistance!

FOUND 51583 RELATED QUESTIONS

3 Answers

Tiny

factoryjack

June, 22, 2010 AT 8:15 AM

If you are getting the rapid clicking from under the hood, it sounds like there is not enough voltage to hold in and turn the starter. Have you tried to jumpstart the vehicle, and have checked that the battery cables are tight. It takes a lot less amperage to run the accessories, and the battery still may not be strong enough to supply the amps to turn the engine over.

Tiny

Wahoo73

June, 22, 2010 AT 9:44 AM

I removed the battery cables, cleaned the battery terminals and reconntected the cables, and then tried jump-starting the car with no success. I then charged the battery overnight. The car did start this morning, but I suspect that it may not hold the charge. I'll have the battery tested and see.

Tiny

factoryjack

June, 22, 2010 AT 11:18 PM

Let me know.

Please login or register to post a reply.

Crank Angle Sensor Replacement Mercedes Benz
Crankshaft Position Sensor Replace Chevrolet
Fuel Pump Replacement Ford Mustang
Fuel Pump Test Chevy Tahoe
Fuel Pump Pressure Test
Fuel Pump Replacement