2001 BMW X5 Transmission problem

Tiny
WAAT
  • MEMBER
  • 2001 BMW X5
  • V8
  • 4WD
  • AUTOMATIC
  • 80,000 MILES
I'm having the same problem that Walz posted on August 6, 2008.

After driving for a while, the transmission does not shift properly anymore. The first 5 to 10 minutes the transmission works fine.

After that, it is as if the car goes into maunal mode by itself and the shifting point is much too high. I need to rev the engine to about 4K - 5k rpms before shifing occurs from 2nd to 3rd gear. Usually it would shift much sooner, around 2K to 2.5K. When I jam on the accelerator I can get it to shift into 3rd -- but, then on its own, it will downshift to 2nd.

And, auto down shifting occurs too soon when comming from higher gears, leading to a jerky braking at traffic lights as the revs are too high on the downshift.

I also tried to change gears in manual mode.
When I want to shift into 3rd gear at revs below 4K it would not engage the gear and the display would show a drop back to 2nd after 3rd was shown on the panel for a brief moment. Same thing occurs when manually shifting from 1st to 2nd and 2nd to 3rd, etc. Can only shift when rpms are above 4k.

Anyone know what's going on here?
Do you
have the same problem?
Yes
No
Monday, November 3rd, 2008 AT 12:57 PM

1 Reply

Tiny
DAVE H
  • MEMBER
Sounds to me like one of the transmission sensors is overheating or something of that kind? I would expect you to get a fault showing on the display or at least get a DTC. But as iv'e seen in the past this is not alway's the case. I would get your ECU read to see if any faults showing. If none present, tracing the fault could be difficult?
Was this
answer
helpful?
Yes
No
Thursday, November 6th, 2008 AT 12:52 PM

Please login or register to post a reply.

Recommended Guides