Battery light goes on and off and transmission will not always shift

Tiny
AUDIOGRL1
  • MEMBER
  • 2000 PLYMOUTH BREEZE
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 140,000 MILES
My power steering went out about a year ago. My battery light came on about a month ago. The car ran for a week with the light on then wouldn't start. I had it jumped and the battery light went off and had no problems for about a week. The battery light came back on and the car would not shift out of first gear. We had the altonater checked and they said it was holding a charge and it needed a new battery. We replaced the battery. The light stayed off for a week or so, but is now back on, and is now having trouble shifting gears. Sometimes will not shift out of park, sometimes it does. Right now it will not shift out of first. The battery light dims sometimes when I press the gas trying to get it to go. I am lost. Please help.
Do you
have the same problem?
Yes
No
Friday, January 31st, 2014 AT 9:11 AM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
It sounds like you have a bad alternator. Was it checked with the light on the last time it was tested?
Was this
answer
helpful?
Yes
No
-1
Friday, January 31st, 2014 AT 9:52 AM
Tiny
AUDIOGRL1
  • MEMBER
Yes it was checked with the lights on. Would it act this way if it needed transmission fluid?
Was this
answer
helpful?
Yes
No
Friday, January 31st, 2014 AT 11:11 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
No, there is no relationship between the trans fluid and the alt light.
Was this
answer
helpful?
Yes
No
-2
Tuesday, February 4th, 2014 AT 4:32 AM

Please login or register to post a reply.

Sponsored links