Air Blowing out Hot (like a furnace)

Tiny
CHRISTYLUTZ
  • MEMBER
  • 2003 CHEVROLET TAHOE
  • 160,000 MILES
I took my 2003 Tahoe into a shop for them to replace the alternator and also the windshield washer reservoir. At this time, the AC did not work because the compressor was out, but I could still use the fan to keep the air cirulating in the vehicle. When they returned it to me, the air coming out of the vents, when using the fan, was like a furnace. It was burning hot. They are saying that they didn't do anything to cause this change, but I know my car and this is something new that didn't start occuring until they worked on it. Can you tell me if there is something they might have touched in replacing the alternator and the windshield washer reservoir that could have caused the air to intake really hot air?
Do you
have the same problem?
Yes
No
Monday, June 10th, 2013 AT 9:42 AM

3 Replies

Tiny
CARADIODOC
  • EXPERT
GM has a really big problem with their generators. You can expect a repeat failure if the battery wasn't also replaced, unless it is less than about two years old. Due to their design they develop huge voltage spikes that can destroy its internal diodes and voltage regulator, and they often damage computers on the truck. The battery dampens and absorbs those spikes but it loses its ability to do that as it ages. Your AC / heater system uses a very unreliable computer that is susceptible to those voltage spikes. It was likely damaged by the old generator or the new one. It could have appeared to work with the old generator on the functions you were using, but the problems could show up now with the new generator and higher system voltage. It's also possible the new generator caused the damage to the computer if the battery is fairly old.

What was the original symptom that required replacement of the generator?
Was this
answer
helpful?
Yes
No
Monday, June 10th, 2013 AT 11:20 AM
Tiny
CHRISTYLUTZ
  • MEMBER
The vehicle started to turn off automatically while I was driving it and I was able to get it parked. We thought it might be the battery, but weren't sure, as we aren't mechanically inclined. We replaced the battery and it was enough to get it to the shop but then it died again. The mechanic told us it was the alternator.
Was this
answer
helpful?
Yes
No
Monday, June 17th, 2013 AT 8:53 AM
Tiny
CARADIODOC
  • EXPERT
It sounds likely the heater / AC computer was damaged by the old generator. Due to their design, that is a fairly common problem. At the risk of locking up the radio or other computers on the truck, you can try disconnecting the negative battery cable for a couple of minutes. In some cases that will reset a confused computer. I don't like to recommend that because the GM engineers have devised a number of tricks that require you to take the vehicle to the dealer. Simply disconnecting the battery can lock up some computers and the dealer has to unlock them. They started that nonsense on some 2003 models.

You can also check for a leaking or disconnected vacuum hose under the hood. Some heater control systems use vacuum motors to run the temperature and mode doors. Usually they are spring-loaded to default to heat / defrost when there's a failure so for safety the windshield will be clear.
Was this
answer
helpful?
Yes
No
Monday, June 17th, 2013 AT 10:25 AM

Please login or register to post a reply.

Recommended Guides