2009 Chevrolet Aveo limp mode/several issues

Tiny
CRHAGA00
  • MEMBER
  • 2009 CHEVROLET AVEO
  • 4 CYL
  • FWD
  • AUTOMATIC
I bought a 2009 chevy aveo LT 2 years ago and noticed the trans wasn't shifting right and there were other noises. I replaced the O2 sensors and was told the rings in the trans were being worn down when it slips causing my fluid to turn black. I have had the fluid flushed and filter replaced 3 times since. My current problem started this past winter when the hold light would come on and flash causing the trans to not shift into higher gears. Then 2 months ago the check engine light came on also. After that the car started to lose power and shake. We replaced the plugs and coil pack fixing the power and shaking but the hold light and check engine light came back on only this time I don't seem to have the shifting problem but the temp gauge and air condition stop working when the lights are on which is 99% of the time. Any ideas? I know it is called limp home mode caused by faulty sensors but where do I start?
Do you
have the same problem?
Yes
No
Wednesday, June 18th, 2014 AT 8:06 AM

7 Replies

Tiny
SATURNTECH9
  • EXPERT
Start by having it scanned for codes and let me know the exact code numbers not code descriptions? Thats where we need to start.
Was this
answer
helpful?
Yes
No
Wednesday, June 18th, 2014 AT 10:18 PM
Tiny
CRHAGA00
  • MEMBER
It reads 3 codes but all are the same. P0128 coolant thermostat (coolant temp below thermostat regulating temp). Does the thermostat need replaced or is it reading this because the gauge isn't working?
Was this
answer
helpful?
Yes
No
Tuesday, June 24th, 2014 AT 4:24 PM
Tiny
SATURNTECH9
  • EXPERT
That's the code for a bad thermostat but that wont put you into limp mode though. Did you do a free code scan at the auto parts store?Or use a diyer scan tool?
Was this
answer
helpful?
Yes
No
Tuesday, June 24th, 2014 AT 8:29 PM
Tiny
CRHAGA00
  • MEMBER
I bought a code reader and did it myself.
Was this
answer
helpful?
Yes
No
Thursday, June 26th, 2014 AT 7:34 AM
Tiny
SATURNTECH9
  • EXPERT
Your code reader wont show all the codes in all the computers unless you spent a lot of money and bought a professional one that can read all the codes.A thermostat stat code wont out that car in limp mode.
Was this
answer
helpful?
Yes
No
Thursday, June 26th, 2014 AT 12:10 PM
Tiny
TCHAVEZ71
  • MEMBER
I have an 09 aveo stuck in lomp mode. It happened after a hot pos cable came into direct contact with the trans directly. I replaced every accessible trans sensor with no change, tested to make sure I had ref voltage going to all sensors and finally replaced the tcm. Only to have it not communicate. Gm dealership said that the tcm needs no programming and shout work out of the box. Which is contrary to everything ive heard. I contacted a trans specialist in town who assured me that it did need to be programmed or "flashed" however after he had my car for a few weeks he called and told me that the tcm I bought is not right. And it doesnt contain the propper programming for my car. Its a 2009 chevy aveo ls. 1.6 litre with alsin 4 speed. The shop told me that the car I have was actually produced in south korea and is more of a daewoo than a chevy. So what it boils down to, im almost positive the tcm is the issue ( no speedo stuck in third. No hold light") I just need to know if there really is daewoo progaming for my 2009 chevy and where can I find it?
Was this
answer
helpful?
Yes
No
Monday, February 22nd, 2016 AT 4:54 PM
Tiny
SATURNTECH9
  • EXPERT
Iam sorry but your going to have to start your own question. One person per question otherwise it gets way to confusing for everyone including other people searching questions to help them fix there cars.
Was this
answer
helpful?
Yes
No
Monday, February 22nd, 2016 AT 10:06 PM

Please login or register to post a reply.

Recommended Guides