Speaker noise in rear

Tiny
GUYMR
  • MEMBER
  • 2008 CHEVROLET SUBURBAN
  • 80,000 MILES
Hi my vehicle has started making what appears to be a static noise in my rear speakers, this goes away when I turn off the rear speakers from the console or if I shut the radio off completely. I have the navigation model on a LTZ.
Do you
have the same problem?
Yes
No
Monday, November 11th, 2013 AT 11:35 AM

3 Replies

Tiny
CARADIODOC
  • EXPERT
It sounds like the vehicle communication interface module could be going out. Here are the wiring diagrams so you can see how the system works.

Check out the diagrams (below).

Please let us know what you find. We are interested to see what it is.

Cheers
Was this
answer
helpful?
Yes
No
Monday, November 11th, 2013 AT 1:33 PM
Tiny
GUYMR
  • MEMBER
They have looked at it once and although they were not sure, they suggested replacing the amplifier and radio, to the tune of $1,300.00 which they thought would get rid of the problem, shockingly I am not going to do that in the hope it would work.

I will keep looking as it seems several other folks have had this problem with a fix being the grounding/shielding of the wires in the rear audio control module or amp.

Thanks
Was this
answer
helpful?
Yes
No
Monday, November 11th, 2013 AT 1:36 PM
Tiny
BATESJPB
  • MEMBER
I had this problem and the amp was bad so I got a used one for $100.00 from eBay, FYI.
Was this
answer
helpful?
Yes
No
Saturday, April 21st, 2018 AT 1:46 PM

Please login or register to post a reply.

Recommended Guides