Unusual Increases to RPMs

Tiny
LINEARTISTA
  • MEMBER
  • 2006 FORD EXPLORER
  • 75,000 MILES
2006 Ford Explorer (~75k miles) started to have unusual rpm increases while accelerating (both initial and maintaing speed). Every now and the then the temp gauge will go all the way up and the warning light comes on - and then quickly goes back to normal. This usually happens with the rpms go up to 3 for about minute. What are the possible causes of this behavior?
Do you
have the same problem?
Yes
No
Monday, September 12th, 2011 AT 11:43 PM

4 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
The RPM issue can be a few things. Check to make sure there are no vacuum leaks. Also, check the throttle position sensor. If the check engine light is on, have the computer scanned for trouble codes. Most parts stores will do it for free.

As far as the temp, make sure the coolant if full. If it is, check the thermostat and cooling system for restrictions.
Was this
answer
helpful?
Yes
No
Tuesday, September 13th, 2011 AT 2:41 AM
Tiny
LINEARTISTA
  • MEMBER
Thank you! There are no warning lights at all. There are no warning lights on my dashboard whatsoever. Had a throttle body cleaning (in addition to oil change, power steering exchange, fuel system service) today. They were going to do a transmission check, but mine is sealed so they couldn't get to it. The 18 point service check list from Mobil Express shows everything is good.
Was this
answer
helpful?
Yes
No
Tuesday, September 13th, 2011 AT 2:46 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
The transmission is sealed, but there is a check point on the side to make sure the fluid is full and clean. They should have checked that.

As far as the engine temp, do you think it is actually getting that hot or do you feel there is an electrical issue?
Was this
answer
helpful?
Yes
No
Tuesday, September 13th, 2011 AT 3:14 AM
Tiny
LINEARTISTA
  • MEMBER
I do not think it is actually getting hot. While the work done yesterday appears to have helped a little, it is still doing it. My mpg is usually around 17 and now it is at 15.8. This morning, the check tire pressure light came on for 5 mins and then went off. Just had them checked yesterday and they were fine. I am going to take it to Firestone today with a print out of this message string. I truly appreciate your help!
Was this
answer
helpful?
Yes
No
Tuesday, September 13th, 2011 AT 1:35 PM

Please login or register to post a reply.

Recommended Guides