2004 Mazda RX8 Ignition

Tiny
ABABCO1
  • MEMBER
  • 2004 MAZDA RX8
  • 2.6L
  • 2WD
  • MANUAL
  • 84,000 MILES
I have recently replaced the clutch pedal due to the manufacturers defect of the support bracket snapping at the weld points. The new pedal is in and seems to be working properly. The battery had drained while sitting for a week and 1/2 while waiting for new pedal to be delivered. The battery is fully charged however I am not getting any turn over when trying to start the car. I am thinking this is due to an adjustment issue with the pin that compress the Hydraulic clutch. Am I in the right ballpark or do I need to be concerned about alternator or a starter issue. The car was performing perfectly before the pedal issue. Thank you for your assistance.
Do you
have the same problem?
Yes
No
Monday, October 13th, 2014 AT 5:34 PM

5 Replies

Tiny
SATURNTECH9
  • EXPERT
Does all the dash lights come on with the key?If so sounds like a issue with the clutch switch not getting pressed all the way in with the clutch pedal pressed all the way down.
Was this
answer
helpful?
Yes
No
Monday, October 13th, 2014 AT 5:56 PM
Tiny
SATURNTECH9
  • EXPERT
Do you have a multi meter to do some testing?
Was this
answer
helpful?
Yes
No
Monday, October 13th, 2014 AT 5:58 PM
Tiny
ABABCO1
  • MEMBER
Its the clutch safety switch. Keep the 5 bucks
Was this
answer
helpful?
Yes
No
Monday, October 13th, 2014 AT 6:28 PM
Tiny
ABABCO1
  • MEMBER
Its the safety switch. Its not compressing far enough to complete the circuit
Was this
answer
helpful?
Yes
No
Monday, October 13th, 2014 AT 6:28 PM
Tiny
SATURNTECH9
  • EXPERT
Glad to hear you got it figured out thats what we like to hear.
Was this
answer
helpful?
Yes
No
Monday, October 13th, 2014 AT 6:55 PM

Please login or register to post a reply.

Recommended Guides