2004 lasabre blower

Tiny
THOMAS234
  • 2004 BUICK LESABRE
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 120,000 MILES

No heat in car because blower not blowing


Do you
have the same problem?
Yes
No
Monday, January 17th, 2011 AT 12:08 AM

6 Replies

Tiny
SATURNTECH9
  • EXPERT
  • 30,995 POSTS

So it doesn't work on any speed?Have you checked the fuse's?Do you have a multimeter?

Was this
answer
helpful?
Yes
No
Monday, January 17th, 2011 AT 12:20 AM
Tiny
RASMATAZ
  • MEMBER

Your probable causes here could be the blower motor, relay, resistor, blower switch and AC/Heater fuse-

Was this
answer
helpful?
Yes
No
Monday, January 17th, 2011 AT 12:22 AM
Tiny
THOMAS234
  • MEMBER

Blower doesn't work at any speed. I checked the fuses(not sure witch fuse is the right one- pulled several).I don't have multimeter, but can borrow one. I the past the blower would quit for a few seconds then it would be o.K..

Was this
answer
helpful?
Yes
No
Monday, January 17th, 2011 AT 12:36 AM
Tiny
SATURNTECH9
  • EXPERT
  • 30,995 POSTS

Alright let me know when you get a multimeter.

Was this
answer
helpful?
Yes
No
Monday, January 17th, 2011 AT 1:08 AM
Tiny
THOMAS234
  • MEMBER

O.K. Saturntech9. Would appreciate your thoughs about the reason the blower motor stopping and starting (on its own )in the past!THANKS FOR TAKING THE TIME TO HELP OTHERS. THOMAS234

Was this
answer
helpful?
Yes
No
Monday, January 17th, 2011 AT 1:38 AM
Tiny
SATURNTECH9
  • EXPERT
  • 30,995 POSTS

You could have a bad switch that make's contact sometimes loose connection somewhere bad motor?That's why we need the multimeter to see whats going on.

Was this
answer
helpful?
Yes
No
Monday, January 17th, 2011 AT 2:00 AM

Please login or register to post a reply.

Recommended Guides