SECURITY LIGHT IS STAYING ON

2003 Saturn Vue

Tiny

jr3289

May, 20, 2012 AT 5:04 AM

I have a 2003 Saturn Vue. The security light has been on and off for the last year. It does not affect starting gauges or any other accessory. I ran my tech 2 to check for dtc, but did not come up with any. No codes stored in the bcm. I replaced the ignition. My GM tech tool was hooked while driving and waited till the security light came on before I checked for codes.

FOUND 540 RELATED QUESTIONS

9 Answers

Tiny

saturntech9

May, 20, 2012 AT 5:56 AM

The info was cut off above so I couldnt see it all. Could you please explain it again?Also does the gas gauge temp gauge power door locks keyless entry ever become inop?

Tiny

jr3289

May, 20, 2012 AT 6:16 AM

I have a 2003 saturn vue. The security light has been on and off for the last year. No problems in starting or any gauges or anything that is wired into the body control module. I scanned with my gm tech 2 and came up with no codes. Security light was on when I hooked up my tech 2. I have replaced the ignition cylinder with new key assembly and passlock sensor. Still light comes on and off. I also replaced the tin connector on the passlock sensor with a copper coated connector. Ive been reading more articles on this and should check the passlock sensor voltage with car off and igition in run condition. Gm mechanic states it is common for the harness off the passlock sensor to the bcm has a tendency to get high resistance. Any more troubleshooting ideas?

Tiny

saturntech9

May, 20, 2012 AT 6:20 AM

So you replace the ignition housing that contains the pass lock sensor.

Tiny

jr3289

May, 20, 2012 AT 6:26 AM

Yes, still security light comes on, but no electrical problems.

Tiny

saturntech9

May, 20, 2012 AT 6:42 AM

Heres what I found for security light always on or flashing when it comes back on follow the trouble tree I posted.

Tiny

jr3289

May, 20, 2012 AT 6:52 AM

Thanks I will give that a try.

Tiny

saturntech9

May, 20, 2012 AT 7:12 AM

Alright let me know what you find most of the ones I have seen like that have been a bad pass lock sensor but those set codes or a bad body control module.

Tiny

jr3289

May, 20, 2012 AT 5:59 PM

Ok, I ran the test with my tech 2 and commmanded the security light on and off. It works fine. According to a 28 year gm vetereran mechanic the voltage at the run position (with car off) should be at least 5.0 volts, mine was 4.75. Do you have any more specifications. I think I need to clean contacts at the bcm and check for high resistance in the passlock harness.

Tiny

saturntech9

May, 20, 2012 AT 9:07 PM

Thats only .25 volts that could be meter error connection error your meter leads etc. You can try checking connections wires etc that wouldnt be a bad thing. The strange part is there are no codes setting.

Please login or register to post a reply.

Door Lock Replacement Toyota 4Runner
Fix a Door That Will Not Close With Ease
Brake Light Bulb Replacement Subaru Legacy
Brake Light Bulb Replacement Mercedes Benz ML
Code Read Retrieval/Clear Mercedes Benz