DID COMPRESSION CHECK AND NOW HAVE NO TACH ...

2003 Nissan Altima

Tiny

david warren

October, 23, 2012 AT 3:54 AM

Did compression check and now have no tach signal. Car wont start without it. Any suggestions?

FOUND 51583 RELATED QUESTIONS

3 Answers

Tiny

KHLow2008

October, 23, 2012 AT 5:22 PM

If you have a scan tool, check for trouble codes. No tach signal could mean the crank sensor is not sending signals to the PCM.

Recheck the work done while testing the compression. A wireharness connector could be not securely plugged in. Ensure any ground circuits removed are secured.
Have you checked for sparks anf eul pressure? Did you check for b, own fuses?
Is the immobilizer triggerred?

Tiny

david warren

October, 24, 2012 AT 1:19 AM

I checked all fuse in car and engine compartment. The vehicle started with ether but ran horribly. What is the immobilizer?Is it the remote security controller?Thank you for your input KHLow2008

Tiny

KHLow2008

October, 24, 2012 AT 12:41 PM

Not the remote, that is the keyless entry and anti-theft. The immobilizer is another security system that prevent engine from starting. There should be an LED or Key symbol indicator for this.

The fuel injectors are not pulsing and this can be due to the cam sensor. Check its wire harness connector. Ensure it iplugged in snugly and tight.

Please login or register to post a reply.

Crankshaft Position Sensor Replace Chevrolet
Crank Angle Sensor Replacement Mercedes Benz
Fuel Pump Pressure Test
Fuel Pump Replacement