2002 Chevrolet Suburban electrical problems

Tiny
AR85ESTES
  • MEMBER
  • 2002 CHEVROLET SUBURBAN
  • 5.2L
  • V8
  • 4WD
  • AUTOMATIC
  • 218,000 MILES
I tried installing an after market audio system. I spliced a rc converter behind the stock deck on to the two front speaker wires. It worked once then I shut the vehicle off then back on and I got no sound from my speakers even though the deck was still saying it was playing. The next day I pulled the deck out and re spliced the wires and again it worked until I shut the vehicle off and refused to work when I turned it back on. A couple days later I was driving down the highway and my instrument panel stopped working. Speedo, tach, gas gauge, oil pressure, voltage gauge and water temp. I thought maybe the system felt an extra draw from my stereo amp and a safe guard kicked in to deactivate unnecessary components so I took out the wiring for the speakers. This solved my radio, now that's back to stock and playing music. I've checked all my fuses and nothing is blown, the illumination lights behind the gauges work and the lcd display still works which is displaying the battery light but the gauges don't work.
Do you
have the same problem?
Yes
No
Thursday, March 19th, 2015 AT 4:21 PM

1 Reply

Tiny
CJ MEDEVAC
  • EXPERT
I'M GONNA LINK YOU TO ANOTHER POST ANSWERED BY THE BEST QUALIFIED EXPERT HERE AT 2CARPROS

http://www.2carpros.com/questions/2004-chevrolet-malibu-audio-system-upgrade

IF YOU HAVE ANY OTHER QUESTIONS FOR HIM, RETURN HERE AND LET ME KNOW

I WILL ATTEMPT TO CONTACT HIM VIA MESSAGES AND POSSIBLY HOOK Y'ALL UP

THANKS FOR WAITING PATIENTLY, "DOC" USUALLY SCOOPS UP ANY AUDIO RELATED QUESTIONS PERTTY QUICK!

THE MEDIC
Was this
answer
helpful?
Yes
No
Saturday, March 21st, 2015 AT 12:05 PM

Please login or register to post a reply.

Recommended Guides