There guys

Tiny
KNIGHTRIDER2929
  • MEMBER
  • 2002 CHEVROLET BLAZER
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 147,000 MILES
Hi there I have 2002 chevy blazer 4.3 litre v6 vortec 2 door 4 wheel drive vehicle I just had the fuel pump replaced and fuel filter and coil wire they say they replaced and checked codes and such, it starts all the time which is good cause the fuel pump just finally died once I have it started it may run a for a few minute or less and when I start going somewhere it still doing the hesitation when I slow down and then start to go again either straight or going around a corner sometimes it feels liek it might stall or something still is wrong but after awhile of driving it doenst seem to do it anymore whats up with that I even put in really good gas and also after the fix I put in fuel infector stuff top quality stuff I have done lots with gasing up not every time, I have always put in good gas, so whats up with that could it be the fuel injectors and also when they put the hose I guess to where you put in gas the opening the silver metal piece that covers the whole that pushes open when you put in the gas it seems moved not int place is thata concern for me

chris
Do you
have the same problem?
Yes
No
Tuesday, December 14th, 2010 AT 11:38 AM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
First, has the fuel pressure been checked since the work was done? Have you checked for vacuum leaks (especially around the intake)? Has the check engine light come on? Finally, as far as the filler tube for the gas, I think I understand what you mean. If it has moved slightly, it shouldn't be a problem. Check to make sure it isn't loose. If it is tight, don't worry.

Let me know.
Was this
answer
helpful?
Yes
No
Friday, December 17th, 2010 AT 3:08 AM

Please login or register to post a reply.

Recommended Guides