I had my alternator replaced now my truck is at.

Tiny
SJC12345
  • 2001 LEXUS RX 300
  • 130,000 MILES

I had my alternator replaced now my truck is at 4rpm when I do 60mph, anyone can help me, is it possible that the alternator has anything too do with this, and why is the rpm at 4, feels like the trannie will not change gears feels like it's stuck in 3rd. Trannie is not oringianall had it replaced severall years ago. Has around 30k miles on it. Machanic claims I need a new computer now. Trust him just not a very good mechanic

Do you
have the same problem?
Yes
No
Tuesday, December 25th, 2012 AT 7:21 PM

31 Replies

Tiny
ASEMASTER6371
  • EXPERT
  • 25,517 POSTS

If he is not very good then why are you there as he may have made a mistake in the repair?

Have him go over all his work to see if he left any connectors off before assuming you have an internal issue

Roy

Was this
answer
helpful?
Yes
No
Tuesday, December 25th, 2012 AT 7:25 PM
Tiny
SJC12345
  • MEMBER

How do you know if anything is bad unless they make a mistake 2 x or more in my case that's what happened,
But the problem is still the same, not why I use the mechanic but why after he replaced the alternator my rpm are at 4 while doing 60mph. Please just looking for help

Was this
answer
helpful?
Yes
No
Tuesday, December 25th, 2012 AT 8:15 PM
Tiny
SJC12345
  • MEMBER

I'm reading there's a possibility that the alternator can be the issue, can anyone please help me with this as I'm at a loss and wanna resolve the issue, can anyone please help me

Was this
answer
helpful?
Yes
No
Tuesday, December 25th, 2012 AT 8:18 PM
Tiny
SJC12345
  • MEMBER

I brang the truck back too him and of cause he hooked up the computer and tells me now that it's the computer on the truck, I have too beleive that's not the issue, The car ran beutiful before the replaced alternator, The car is a 2001 lexus and has more sensor's then egine parts, I read that an alternator can mess with multiable parts, my suspsion is he put a cheap alternator and will not admit he messed up, Who likes too admit fault

Was this
answer
helpful?
Yes
No
Tuesday, December 25th, 2012 AT 8:27 PM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,517 POSTS

If the new alt is bad and putting out ac voltage instead of dc voltage, then yes, it could cuse other issues but not shifting into overdrive would be 1 of many other issues.

Did he say there were any codes when he put it back on the scanner?

Roy

Was this
answer
helpful?
Yes
No
Tuesday, December 25th, 2012 AT 8:57 PM
Tiny
SJC12345
  • MEMBER

ASEMaster6371
You seem too have a great reputaion, I would and need your expertise, via phone or e-mail. I'm willing too pay but I really need someone who knows what there talking about. Can you help. As too there a severall issues I need too have answer too

Was this
answer
helpful?
Yes
No
Tuesday, December 25th, 2012 AT 9:14 PM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,517 POSTS

Let me know how I can help you.

Roy

Was this
answer
helpful?
Yes
No
Tuesday, December 25th, 2012 AT 11:03 PM
Tiny
SJC12345
  • MEMBER

ASEMaster6371
I'm sorry I'm new too using this siteand not geting the hang of it, Yes he gave me a code of some sort but when I looked it up it said it meant that the car was being tested, keep in mind that the check eng light is on so its not giving me an ans, the check eng light is a whole other matter that I'm dealing with. But the light was on before That's when I relized he was not a good machanic, we where still dealing with that issue and being my sister uses the car she had him change the alternator, It seems the more he touches it the more I see he just guesses at the problems
All this, like I said He seems honest and was very fare in price, He worked on my Ford explorer and never had a problem with his work, I just beleive that the 2001 lexus is way out of his league

Was this
answer
helpful?
Yes
No
Tuesday, December 25th, 2012 AT 11:12 PM
Tiny
SJC12345
  • MEMBER

I don't have the code in front of me, as far as the eng light He changed the oxygen sensor, then I find out it has 3 so I brang the truck too someone else and they said it was bank 1 sensor he changed that and still the light is on, I put a new gas cap cleaned the MAF sensor and checked for cracked of leaky hoses myself, still light is on, I'm guessing It might be bank 2 sensor but mean while, Now I have too deal with this RPM before I resolve the egn light as I beleive the high RPM can kill the eng of the trasmission

Was this
answer
helpful?
Yes
No
Tuesday, December 25th, 2012 AT 11:18 PM
Tiny
SJC12345
  • MEMBER

ASEMaster6371
Ive got the code, When we took it for a test ride he had the testing computer hook up while driving and the only code that came up was CODE 1201 He ask me too write it down and needed too look into it
any help, Thank you again

Was this
answer
helpful?
Yes
No
Wednesday, December 26th, 2012 AT 1:27 AM
Tiny
KHLOW2008
  • EXPERT
  • 42,001 POSTS

Reconfirm the code. P1201 is not listed in our database nor in generic OBD-II code list.

Was this
answer
helpful?
Yes
No
Wednesday, December 26th, 2012 AT 2:48 PM
Tiny
SJC12345
  • MEMBER

Yes sir that is the code it read, That's what I mean the Lexus is way out of his league and now I pay for it. I'm going today too get a reading from another mechanic as soon as I get the new reading I will post it, Any how have you ever heard of a problem like mine refering too the RPM @4 while doing 69MPH, after a alternator change

Was this
answer
helpful?
Yes
No
Wednesday, December 26th, 2012 AT 3:06 PM
Tiny
KHLOW2008
  • EXPERT
  • 42,001 POSTS

Symptom indicates the OD is most likely not engaging. Does manually turning the OD OFF and ON switch makes any difference to the engine rpm?

If P1201 is the confirmed code, that would mean a fault with the PCM as any code not listed means the PCM is faulty.
Electrical problems can be affected by disconnecting the battery, low or excessive charging. Power surge can damage PCM too.

Was this
answer
helpful?
Yes
No
Thursday, December 27th, 2012 AT 2:34 PM
Tiny
SJC12345
  • MEMBER

No, I've tried playing with the O/D button as I drive and nothing, at first playing with it and bringing the car too a stop would help, I drove about 10 miles with the O/D on and when I took it off the car was fine at 2 RPM at 60mph but now I jsut can't get it down, Should I try fuses? What would I do too see if the O/D is at fault

Was this
answer
helpful?
Yes
No
Thursday, December 27th, 2012 AT 3:33 PM
Tiny
KHLOW2008
  • EXPERT
  • 42,001 POSTS

I would suggest getting another scan done to check for trouble codes.

When the O/d switch fails to work, it could mean the transmission valve body has a fault.

Apart from checking fuses, I would suggest checking the ground circuits. If any is poor, especially for the transmission and its control, it can cause erratic shifting patterns.

Was this
answer
helpful?
Yes
No
Thursday, December 27th, 2012 AT 3:41 PM
Tiny
SJC12345
  • MEMBER

Do you think that the alternator has anything too do with it, I find it strange that after he put's an alternator in I start having RPM problems

Was this
answer
helpful?
Yes
No
Thursday, December 27th, 2012 AT 5:21 PM
Tiny
SJC12345
  • MEMBER

I got a read out from Auto Zone, and there telling be it's the NOC sensor, can that be the culprat for the high RPM @ 60 MPH

And as for as the EGN light after having OXY sencor and Bank 1 sensor changed they tell my the read out says bank 2 sensor

Can this be the answ for the RPM's at 4 doing 60mph and for EGN light, can it be that simple?

Thank you for all your advise and help greatlly appreciated

Was this
answer
helpful?
Yes
No
Thursday, December 27th, 2012 AT 10:28 PM
Tiny
SJC12345
  • MEMBER

Code for lexus 2001 300RX
PO330
PO171
PO174
PO325
Can anyone explane these codes, and also why it says MAF concern, does that mean I should change the MAF sensor as well?
RPM, s at4 while doing 60MPH NOC sensor sound write

Ans ENG light on, sensor 2 Bank 2 sound write

Thank You

Was this
answer
helpful?
Yes
No
Friday, December 28th, 2012 AT 12:47 PM
Tiny
KHLOW2008
  • EXPERT
  • 42,001 POSTS

P0171 and P0174 are system running lean conditions. It could be vacuum leaks or a host of sourves and does not indicate what component is faulty. It could also be due to low fuel fuel pressure or caused by the knock sensor.

P0320 and P0325 - Knock sensors fault, left and right bank respectively.
Knock sensors failure are common for such vehicles.

All the 4 codes have no relations to the transmission not shifting to O/D which can be due to a fault with the O/D solenoid stiicking.

Sometimes problems are coincidental and you should not keep thinking it is related to the alternator replacement. Test the O/D solenoid first.

Was this
answer
helpful?
Yes
No
Please consider a donation if we helped you
Friday, December 28th, 2012 AT 1:03 PM
Tiny
SJC12345
  • MEMBER

Just I understand
When I hit 60 mph and the RPM are @ 4
Feelin as the car not shifting into the next gear that's call overdrive?
I feel the car shift 1st 2nd and 3rd
The next is call O/D?

Was this
answer
helpful?
Yes
No
Friday, December 28th, 2012 AT 1:09 PM

Please login or register to post a reply.

Related Transmission Not Shifting Questions

Recommended articles