STARTED UP BEGAN TO IDLE ROUGH ALL GAUGES, AC, RADIO, ETC SHUT OFF

2001 Chrysler Town and Country

Tiny

Ryanladams

July, 30, 2012 AT 3:37 PM

My van seems to be having electrical issues as it started up but began to idle rough and all the gauges, AC, radio, ect shut off. When I jumped it it began to run fine (AC, radio, wipers, ect). After removing jumper cables it almost immediately began to idle very rough and all electrical components shut off (no gauges or anything). It continued to idle very rough until I depressed the break peddle and it died. Before I tuned the key off, I began to hear a constant clicking coming from the steering column. I also noticed this clicking from the fuse relay box. The clicking stopped after I turned the key off. All of this took place after cleaning the battery posts. About a week prior I had the battery and alternator tested at Auto Zone in which they said they both tested "good". Thank you for any guidance you can offer.
Ryan adams

FOUND 4561 RELATED QUESTIONS

Running Rough

27 ANSWERS
34 IMAGES

Idles Rough/changed Ects

37 ANSWERS
3 IMAGES

1 Answer

Tiny

Docfixit

July, 30, 2012 AT 3:43 PM

Seems as ALT is not working and BATT very discharged. Suggest have system re-tested by trained Tech

Please login or register to post a reply.

Code Read Retrieval/Clear Chevrolet Camaro
How to gather codes Ford Explorer
Code Read Retrieval/Clear Honda Civic
Code Read Retrieval/Clear Mercedes Benz
How to read codes Chevrolet Blazer
Code Read Retrieval/Clear Mercedes-Benz C230