2001 Town and Country, ASD RELAY TRIPPING. HELP!

Tiny
3030TANK@GMAIL.COM
  • MEMBER
  • 2001 CHRYSLER TOWN AND COUNTRY
  • 176,000 MILES
Ok so I'll start by saying I know about as much as the average joe about cars and will tackle minor repairs as long as there isnt a chance of me screwing anything up worse.

So to get the the point, my wife left for work in the van and quickly turned around because it was stuttering/skipping and low on power, definitely didnt feel right. I jumped in it and verified it was definitely idling and running rough.

Ive had the van for 3 years and put a lot of miles on it and never changed the plugs so I figured i'd start with this since it needed it anyways. Changed the plugs, cranked the van back up, drove it, situation was slightly better but still not right, stuttering etc.

Next step was to check the wires, I pulled out my multimeter to check for resistance but since I could not find what an acceptable reading would be online, I figured I'd go ahead and get a set since it probably needed that as well. Autozone had a coil pack for 45 bucks so I picked that up too, figured it was cheap enough to go ahead and knock out that possibility too.

Pulled off the old coil pack and wires, popped the new ones on, connected everything back as it was before. Easy enough. Well

* upon trying to crank the van I get a fast clicking noise that seems to be comming from the ASD relay in the fuse panel. Weirdly enough it still clicks after pulling the key out of the ignition, I have to remove the negative batt cable to stop it. Rechecked all my connections, everything is solidly in place and where it should be. Tried reconnecting the old wires/coil pack because at least then I could start the van, but now I have the same problem with that setup. As far as I can tell, the system isnt even going as far as the coil pack because I get the same clicking noise with no harness connected to the coil pack.

I am at a loss, dont have a ton of money to dump it off at a dealership or somthing to fix a major electrical problem so I figured I'd check here first to see if anyone has any idea what ive screwed up?

Thanks in advance for any help offered
Do you
have the same problem?
Yes
No
Thursday, December 22nd, 2011 AT 1:38 PM

1 Reply

Tiny
DRCRANKNWRENCH
  • EXPERT
I am providing you with fuel sytem tests. The Intelligent Power Module, IPM, contains the ASD Relay and is integrated into it. The fuel pump relay is not integrated and can be replaced. Hopefully it is the fuel pump relay. I think one of the 2 was the issue from the start as the fuel pressure would be irratic and cause the symptoms you are having. When the test refers to using a stethospce to hear the fuel pump, you might be able to get away with having someone place a large flate blade screwdriver on the side of the tank as near the fuel pump. When the ignition is turned to the, "ON" position the pump primes the system by running for about 2 seconds. You are listening for a, "whirring" noise.
I had to break fuel or IPM/ASD test into 2 parts labeled 1of2 and 2of2. All the figuers from tests are labeled as such.
You can also have the trouble codes pulled if all of testing fails at any Advance Auto or Auto Zone for free. You can also get fuel pressure test kit with adapters at either store on loaner basis.
I hope everything works out for you.
Was this
answer
helpful?
Yes
No
+1
Thursday, December 22nd, 2011 AT 3:38 PM

Please login or register to post a reply.

Sponsored links