2000 Jeep Grand Cherokee Laredo - Brake Light Problems

Tiny
PRALOWR
  • MEMBER
  • 2000 JEEP GRAND CHEROKEE
Tail lights are repeatedly going out. Now they will not come on at all. I have replaced the fuses but they blow every time I use the lights. It is just the rear lights. The front lights work fine. I am truly frustrated and really want this fixed as this is my only vehicle. I need help. I just spent 700 bucks to fix the rear lights and they are doing the same thing all over again. Is it a wire? And if so how do I fix it? I have changed bulbs among other things. I need help.
Do you
have the same problem?
Yes
No
Wednesday, December 3rd, 2014 AT 5:25 AM

5 Replies

Tiny
JOHNNYT73
  • EXPERT
Did the repair that was done before correct the issue for a while? If so then I would look into that being the same issue.
Was this
answer
helpful?
Yes
No
+2
Wednesday, December 3rd, 2014 AT 6:34 AM
Tiny
CJ MEDEVAC
  • EXPERT
PLEASE ANSWER JohnnyT73's QUESTIONS 1ST
.
.
.

INSTALL NEW FUSES

REMOVE THE TAIL LIGHT BULBS AND "TWISTY" BULB HOLDERS- LEAVE THEM OUT FOR THIS TEST

TURN YOUR HEADLIGHTS ON

DID THE FUSES BLOW?

DO OTHER STUFF LIKE TURN SIGNALS AND BRAKE LIGHTS

DID THE FUSES BLOW?

IF NOT, MAYBE IT'S THE "TWISTY" HOLDERS, THERE ARE BRASS/ COPPER CONTACT RINGS IN THE FIXTURE AND LITTLE TABS ON THE HOLDER, MAYBE THEY ARE OVERTIGHTENED AND MAYBE TWO CONTACTS ARE BEING TOUCHED AT THE SAME TIME?

WHEN YOU RE-INSTALL

DO ONE THEN "TEST"

TAKE IT OUT

DO THE OTHER, THEN "TEST"

MAYBE THIS WILL RULE OUT ONE SIDE OR THE OTHER AT THE EXPENSE OF A COUPLE OF FUSES

ALWAYS USE THE CORRECT AMP FUSE!

I HAVE SEEN MANY VEHICLES WIRE HARNESSES CATCH ON FIRE

TWO OF WHICH BURNED TO THE GROUND, BECAUSE OF INCORRECT FUSES

I'M COPYING AND PASTING THE INFO I GAVE TO ANOTHER POST IN 2012- HIS LIGHTS WERE NOT COMING ON

KEEP US POSTED AS YOU PROGRESS

MY BESTUS BUDDY HAS A 2000, TAIL LIGHT/ TURN SIGNAL ISSUES.

THE BULB HOLDERS TWIST INTO THE FIXTURE ON THE REAR LIGHTS.

WE DID SOME SWAPPING AROUND OF "TWISTY HOLDERS" AND FOUND THAT THE SMALL CONTACT ON THE HOLDER HAD TO BE BENT OUT A LITTLE MORE, AND THE CIRCULAR CONTACTS ON THE FIXTURE, HAD TO BE SLIGHTLY SANDED, TO CLEAN 'EM UP---JUST FOR "INSURANCE", WE APPLIED A THIN COAT OF DIELECTRIC GREASE ON ALL CONTACT SURFACES (AVAILABLE AT A PARTS STORE, SORTA LOOKS LIKE A TUBE OF SILICONE GASKET)

ALL SEEMS GOOD NOW!

YOUR TURN

THE MEDIC
Was this
answer
helpful?
Yes
No
+1
Wednesday, December 3rd, 2014 AT 4:21 PM
Tiny
PRALOWR
  • MEMBER
JohnnyT73

Thank you for responding.

You are correct. The issue was fixed for a while. It was working great, then it just failed once again. It is truly annoying. Shelling out another 700 bucks, isn't something I want to do for temporary work. Then again, it could be this faulty vehicle. I will keep trying though.

Thanks
Was this
answer
helpful?
Yes
No
Wednesday, December 3rd, 2014 AT 4:29 PM
Tiny
PRALOWR
  • MEMBER
CJ MEDEVAC

I will try your avenues that you have presented. Once I have tried I will update on my progress. I really hope this solves the issue. I will keep you posted.

RP
Was this
answer
helpful?
Yes
No
+1
Wednesday, December 3rd, 2014 AT 4:32 PM
Tiny
CJ MEDEVAC
  • EXPERT
I RECKON I COULDA SUGGESTED UNPLUGGING BOTH ASSEMBLES COMPLETELY, AND ALSO DOIN' THE "ONE AT A TIME THING"

WHILE YOU HAVE IT OUT, INSPECT THE WIRES AT THE CONNECTION TO SEE IF THEY HAVE BEEN PINCHED OR RUBBED RAW AND GROUNDING OUT.

THIS MIGHT ELIMINATE MORE INTERNAL POSSIBILITIES WITHIN THE FIXTURE ITSELF, BEFORE GETTING MORE INVOLVED IN THE REST OF THE WIRING

THE MEDIC
Was this
answer
helpful?
Yes
No
+1
Wednesday, December 3rd, 2014 AT 4:51 PM

Please login or register to post a reply.

Recommended Guides