ONLY STALLS WHEN COMING TO A STOP OR SLOWING DOWN

  • Tiny
  • Erob71
  • 2000 FORD EXPEDITION
  • 188,000 MILES

My 2000 ford expedition keeps stalling and seems to idle real high. When it stalls it starts right up it only stalls when im slowing down at a stop or red light or either when i'm parking or making a slow turn but it starts right back up. I changed the spark plugs, that didnt help. Any idea what this could be?

Do you
have the same problem?
Yes
No
Saturday, March 10th, 2012 AT 9:49 PM

5 Replies

  • Tiny
  • Fixitmr
  • MEMBER

Vacuum leak or malfunctioning IAC/ICV vavle. Any codes to be read?

Was this
answer
helpful?
Yes
No
Saturday, March 10th, 2012 AT 9:55 PM
  • Tiny
  • Erob71
  • MEMBER

No codes that I know of. Can you tell me what an iac/icv is?

Was this
answer
helpful?
Yes
No
+1
Saturday, March 10th, 2012 AT 9:58 PM
  • Tiny
  • Fixitmr
  • MEMBER

Idle control valve

Was this
answer
helpful?
Yes
No
Sunday, March 11th, 2012 AT 10:16 PM
  • Tiny
  • Rcfoote19
  • MEMBER

How you figured out what the problem was.I have same exact problem and had plugs replaced and that didn't work.
Thanks

Was this
answer
helpful?
Yes
No
Thursday, April 19th, 2012 AT 3:04 AM
  • Tiny
  • Jacobandnickolas
  • EXPERT
  • 68,401 POSTS

AS he first mentioned, it could be an issue with a vacuum leak. On the rear of the throttle body is a vacuum line that has a 90 degree turn in it. They have been known to dry rot and leak. As far as the Idle air control valve, remove it and make sure the pintel is moving when the key is turned on and off.

Was this
answer
helpful?
Yes
No
Tuesday, May 22nd, 2012 AT 5:37 AM

Please login or register to post a reply.

Other Engine Stall Questions