Air conditioner stop working

Tiny
UHSNOEBIRD
  • MEMBER
  • 2000 CHEVROLET MALIBU
  • 114,000 MILES
My ac stopped working, I know for sure that the relay is good, when I cross over the two connectors that the relay suppose to join together to send the signal to the clutch it works, I am getting voltage to the relay but my air will not work. It will if I use a jumper wire to join the two that I have mentioned above together. Is it a bad connection from the pins of relay or what? Thank You
Do you
have the same problem?
Yes
No
Wednesday, October 23rd, 2013 AT 6:52 PM

34 Replies

Tiny
CJ MEDEVAC
  • EXPERT
Relay?

Sure?

Not the "low pressure switch"?

If it's the low pressure switch you are bypassing, either you are a little low on gas, or the switch is bad.99% of the time, you are low on gas

this is what came to mind 1st. Maybe you are on a relay elsewhere

the medic
Was this
answer
helpful?
Yes
No
Wednesday, October 23rd, 2013 AT 8:37 PM
Tiny
UHSNOEBIRD
  • MEMBER
I looked for a low pressure switch and cannot find one, I am on the correct relay, have interchanged about 4 different ones, bought a new one to, thinking that it doesn't have a low pressure switch but if it does cannot find it, I know where the low pressure fitting is. Do you have any ideas where it may be located?
Was this
answer
helpful?
Yes
No
Thursday, October 24th, 2013 AT 6:56 AM
Tiny
HMAC300
  • EXPERT
It's on the line in front of engine compartment jump red and black wires
Was this
answer
helpful?
Yes
No
Thursday, October 24th, 2013 AT 7:48 AM
Tiny
UHSNOEBIRD
  • MEMBER
The high pressure switch is in front of the engine but cannot find the low pressure switch unless it is hidden, have looked around accumulator and still cannot find it, sorry if I seem to be ignorant or so, I have some knowledge. I have looked in a service manual and it doesn't mention a low pressure switch. Thank You
Was this
answer
helpful?
Yes
No
Thursday, October 24th, 2013 AT 1:07 PM
Tiny
HMAC300
  • EXPERT
It's not a low pressure switch it's a high pressure switch it's on the line coming from the condenser at front of engine compartment look on passenger side.
Was this
answer
helpful?
Yes
No
Thursday, October 24th, 2013 AT 3:32 PM
Tiny
UHSNOEBIRD
  • MEMBER
Ok, I will try that, it is raining here, might be a day or two before I try that but I will let you know if it works. I am wanting it fixed before spring comes along, there are 3 wires that goes to this switch, are you certain on the colors to cross over ( red & black)?
Was this
answer
helpful?
Yes
No
Thursday, October 24th, 2013 AT 6:30 PM
Tiny
HMAC300
  • EXPERT
Yes because the other is a 5 volt signal wire
Was this
answer
helpful?
Yes
No
Friday, October 25th, 2013 AT 7:03 AM
Tiny
UHSNOEBIRD
  • MEMBER
Ok, Thanks and will let you know the outcome.
Was this
answer
helpful?
Yes
No
Friday, October 25th, 2013 AT 12:24 PM
Tiny
UHSNOEBIRD
  • MEMBER
Today, I crossed over the red and black wires at the high pressure switch, it did not kick the air in, had ignition on with air condition switch on inside of vehicle. I checked for voltage on the signal wire and had 5 volts, from it to ground.
When I take the relay out and cross over the two connections that should work when the relay is energized, it kicks the clutch in at the air compressor. I also double checked for voltage at the connections that energize the relay and it has 12 volt's, I am thinking that the connections aren't connecting like they should be, either to the relay or the ones the relay should join, what do you think? Thinking it is inside the fuse/relay box. Thank You
Was this
answer
helpful?
Yes
No
Saturday, October 26th, 2013 AT 7:29 PM
Tiny
HMAC300
  • EXPERT
Sounds like you found the problem
Was this
answer
helpful?
Yes
No
Sunday, October 27th, 2013 AT 6:13 AM
Tiny
UHSNOEBIRD
  • MEMBER
Ok, thank you for all of your info, have a good day.
Was this
answer
helpful?
Yes
No
Sunday, October 27th, 2013 AT 7:04 AM
Tiny
UHSNOEBIRD
  • MEMBER
I still haven't got my air conditioner going the correct way. I have a few more questions for you if you don't mind. The wiring diagram shows a light green wire going to the body control module & it comes from the AC control module. Is the light green wire a negative voltage or a positive voltage that goes to the Body control module? It also shows a Purple wire coming from the Body Control Module & it goes to the Power Control module.
Is the Purple wire a positive voltage or a negative voltage then the power control module sends the relay a negative voltage to make it work. Thank you
Was this
answer
helpful?
Yes
No
Monday, March 12th, 2018 AT 2:30 PM
Tiny
KEN
  • ADMIN
Hello,

To me it sounds like the system is low on charge but lets go through things to see whats going on.

It does have a low pressure switch which I would replace to see if the system kicks on.

Here is a guide to help as well.

https://www.2carpros.com/articles/car-air-conditioner-not-working-or-is-weak

Lets fix this bad johnny, Ken
Was this
answer
helpful?
Yes
No
Thursday, March 15th, 2018 AT 11:21 AM
Tiny
UHSNOEBIRD
  • MEMBER
Ken, this has a trinary switch on the high side AC line, do I jump 2 of these wires over & if so, which two? Will this blow a fuse? Thank you
Was this
answer
helpful?
Yes
No
Thursday, March 15th, 2018 AT 1:53 PM
Tiny
UHSNOEBIRD
  • MEMBER
By the way, I have tried about 3 different Ac Control panels.
Was this
answer
helpful?
Yes
No
Thursday, March 15th, 2018 AT 1:55 PM
Tiny
KEN
  • ADMIN
Yes that sensor do not jump I thought it was a two wire sorry. Does the system have pressure in it?

https://www.2carpros.com/articles/air-conditioner-how-to-add-freon

Let me know.
Was this
answer
helpful?
Yes
No
Thursday, March 15th, 2018 AT 4:15 PM
Tiny
UHSNOEBIRD
  • MEMBER
Let me go through a few things, I have replaced the AC control panels 3 times with used ones.
The light comes on when I press the AC switch but it doesn't energize the compressor.
The relay isn't getting the ground to it from the PCM & that's why it isn't working correctly.
What I have done is ran a wire through the firewall the the ground side of the relay then back to a toggle switch inside vehicle & the other side of toggle switch to a ground.
When I want the air on I just pull the toggle switch but I have to make sure the AC switch is on or the fan want run & it will blow my freon out of compressor if the fan doesn't keep air flow through the condenser but I want my AC to work the correct way, my freon pressures are correct. What ideas do you have? Thanks for helping me.
Was this
answer
helpful?
Yes
No
Thursday, March 15th, 2018 AT 6:43 PM
Tiny
KEN
  • ADMIN
If the PCM is not grounding it can be the or connection or its not being told to turn on which can be the pressure sensor.

Use this guide and the wiring diagrams about to see where we are losing power or ground.

https://www.2carpros.com/articles/how-to-check-wiring

Please let us know what you find.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Friday, March 16th, 2018 AT 11:13 AM
Tiny
UHSNOEBIRD
  • MEMBER
If it was the pressure sensor I should get the code below :

Trouble Code: P0530 (3.1L V6 VIN J Auto)
A/C Refrigerant Pressure Sensor Circuit Malfunction
Was this
answer
helpful?
Yes
No
Friday, March 16th, 2018 AT 3:06 PM
Tiny
KEN
  • ADMIN
In most cases, which makes me think the charge is low but you say its okay correct?

https://www.2carpros.com/articles/re-charge-an-air-conditioner-system

If everything checks out test the wiring and then the only thin left is the PCM.
Was this
answer
helpful?
Yes
No
Friday, March 16th, 2018 AT 4:34 PM

Please login or register to post a reply.

Recommended Guides