IT WON'T START

1999 Saturn SL1

Tiny

inderbirsinghdeol

February, 24, 2012 AT 6:08 PM

I have a 1999 saturn sl1 4 door 1.8L. My problem is this that yesterday it started making a sound when I go above 40km speed and the sound speed increases with the speed of the car.I live in Barrie, Ontario (Canada). And its snowing today? I tried starting my car. But it won't start. It has battery power in it. If I press accelerator simultaneously when I turn the key on in the ignition then it starts. But it dies again when I release the accelerator to put my car into gear.I cheked the engine oil and everything. Please help me out.I am stuck at work.

FOUND 51579 RELATED QUESTIONS

1 Answer

Tiny

saturntech9

February, 24, 2012 AT 8:33 PM

So it will start when you hold your gas pedal all the way to the floor while trying to start it?If so most likely you have a bad coolant temp sensor really common on those cars. Also inspect the inside of the connector going to it if the terminals are corroded and there green o blue instead of silver then the connector will have to be replaced also. As far as the noise part that sounds scarey can you hear that noise while trying to start it?Withe all that rust uo there it could be something just rusted out a bad wheel bearing etc. Did the noise just start today when it wouldnt start?

Please login or register to post a reply.

Crankshaft Position Sensor Replace Chevrolet
Crank Angle Sensor Replacement Mercedes Benz
Fuel Pump Test Chevy Tahoe
Fuel Pump Replacement