WASHER PUMP

1999 Ford Explorer

Tiny

rmoore09

January, 8, 2012 AT 3:46 AM

Hello, My windshield washer pump sometimes will work but not always. When I press the button the wipers will move but the fluid wont spray. Sometimes it will spray. What could be the problem?

FOUND 111 RELATED QUESTIONS

6 Answers

Tiny

saturntech9

January, 8, 2012 AT 5:03 AM

Do you have a multimeter to do some testing?

Tiny

rmoore09

January, 8, 2012 AT 10:16 AM

Yeah, Im an Electronics Technician lol, Should I check the fuses?

Tiny

saturntech9

January, 9, 2012 AT 12:37 AM

Sorry it took so long to respond but I havent been getting my email alerts to say I got response to questions I have answered. If it works sometimes its not the fuse. When its inop see what your missing power or ground. Lets start there.

Tiny

CJ MEDEVAC

January, 9, 2012 AT 2:07 AM

I STUMBLED ON A POST W/ NO ALERT---SENT MESSAGE TO MIKE

I DON'T ANSWER "IN VOLUME" AND MIGHT GO DAYS WITHOUT AN ALERT ANYWAY

ARE YOU GETTING THEM NOW saturntech9?

THE MEDIC

Tiny

cadieman

January, 9, 2012 AT 2:24 AM

Check the switch in the jug remove it and check the screen on it. It may need cleaning including the jug. If thats clean and the motors running. Check for clogged nozzles

Tiny

saturntech9

January, 9, 2012 AT 4:56 AM

If the inlet screen is clogged on the washer pump the pump will be loud and have a high pitched sound while running.

Please login or register to post a reply.

Windshield Washer Reservoir Replacement
Wiper Blade Replacement Scion XD
Windshield Wiper Replacement
Wiper Blade Replacement Acura MDX
Wiper Blade Replacement GMC Yukon
Wiper Blade Replacement Chevrolet Camaro