1999 Dodge Neon

Tiny
JAMES ROY BENNETT
  • MEMBER
  • 1999 DODGE NEON
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 123,000 MILES
I have a 1999 dodge neon, 2.0 engine. It has 123,000 miles. The engine cranks real slow to start, but starts. I checked the battery voltage and it is a little over 12v with the engine off. After starting the engine it goes to 14.3 volts. The battery was put in in 2009. Does this sound like the battery is just weak, or could my timing be off due to the mileage and the timing belt not being changed yet. Just yesterday it started really rough and the check engine light came on, but finally settled out. The fault codes were P0300, P0302, P0303. One of my plugs is gapped at.040.
What do you think.

Thanks
Do you
have the same problem?
Yes
No
Tuesday, December 7th, 2010 AT 2:59 PM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
THe codes are for cylender misfires. That wouldn't cause it. As far as the battery, one would think it is fine being that new, but it wouldn't hurt to have it load tested at a parts store. If it checks good, then I recommend having the starter draw checked. It may be bad and drawing too many amps.

Let me know what you find.
Joe
Was this
answer
helpful?
Yes
No
Tuesday, December 7th, 2010 AT 3:01 PM
Tiny
JAMES ROY BENNETT
  • MEMBER
Thanks for the advice, I will proceed.
Was this
answer
helpful?
Yes
No
Wednesday, December 8th, 2010 AT 2:13 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Let me know what you find.
Joe
Was this
answer
helpful?
Yes
No
Wednesday, December 8th, 2010 AT 6:37 PM

Please login or register to post a reply.

Recommended Guides