IT IS A SEBRING LXI AUTOMATIC

1999 Chrysler Sebring

Tiny

Anonymous

November, 13, 2012 AT 3:31 PM

It is a Sebring LXi automatic.

My car started to show two problems.

1. Sometimes, specially while driving in heavy traffic for quite some time, the Engine light comes on and the engine looses power, it keeps on running but it does not accelerate at all. Turning the engine off and on will not make the problem go away, but if I sit still for sometime until the engine cools down, or at least that is what I think it does, the car starts acting normal. Driving the car on a high way at cruise speed will not make the problem appear. I took the car to the autozone and they run a computer check and it returned a faulty oxygen sensor, I replaced the sensor but the problem is still there.

2. The second problem is with the brakes, it feels like the car drags on to far even if I step on the brakes all the way in, I have come close to hit two cars because the car just wouldn't brake, it brakes very poorly, I have checked the pads and the brake fluid level and both seem to be OK. I have been told that it is the ABS system, but I have driven several cars with ABS system and none behaves like this, they don't lock the wheels but they do stop at a considerate distance, the sebring is way passing 3 times the distance that the other cars would.

FOUND 17085 RELATED QUESTIONS

0 Answers

Please login or register to post a reply.

Code Read Retrieval/Clear Scion XD
Code Read Retrieval/Clear
Code Read Retrieval/Clear Chevrolet Camaro
 Step by Step video GMC Yukon XL 2000-2006
Code Read Retrieval/Clear Honda Civic
Code Read Retrieval/Clear Mercedes-Benz C230
How to gather codes Ford Explorer