1999 Suburban not cranking

Tiny
JAYNEMEALS
  • MEMBER
  • 1999 CHEVROLET SUBURBAN
  • 153,000 MILES
1999 Suburban 1500 LS, will not crank - no sound at all. Have been using it for a month with no problems. Battery checked and it is fine, lights, radio and gauges come on. Could it be the fuse or some other easy item I could fix?
Do you
have the same problem?
Yes
No
Sunday, March 27th, 2011 AT 8:53 PM

7 Replies

Tiny
SATURNTECH9
  • EXPERT
So battery test's good?Battery cables are clean and tight?Do you have a multimeter or test light to trace power?
Was this
answer
helpful?
Yes
No
Sunday, March 27th, 2011 AT 8:56 PM
Tiny
JAYNEMEALS
  • MEMBER
No, I do not have a multimeter or test light. I am not a mechanic. I am making an assumption that the battery is good because everything else works on the truck that is electrical. I was getting ready to leave, put the key in the ignition, turned the key and there was no sound indicating that the ignition was trying to turn over or crank. I have located the fuse box so I guess I will try to find #8 for the 'crank'. Sorry I can not be more specific, I am only borrowing the suburban and do not know it's mechanical or repair history. There are fuses all over the floor so that is why that was the 1st thing I thought it could be. I am sorry if I took up too much of your time.
Jm:(
Was this
answer
helpful?
Yes
No
Sunday, March 27th, 2011 AT 9:09 PM
Tiny
SATURNTECH9
  • EXPERT
Its ok I always have the battery tested assuming the battery is good can turn into a big headache always to check the basic stuff first battery and cable's etc. If you think it's a fuse then check the fuse's. If it isn't then get at least a test light and I will help you trace the problem down.
Was this
answer
helpful?
Yes
No
Sunday, March 27th, 2011 AT 9:22 PM
Tiny
JAYNEMEALS
  • MEMBER
Thanks, I will check the fuse and eventually someone will come out to the country to retreive me to go and get the test light! Only problem with living so far out. You are s-o-l when your transportation breaks down and you have loaned out your back-up-car! Have a nice afternoon. Jm:)
Was this
answer
helpful?
Yes
No
Sunday, March 27th, 2011 AT 9:26 PM
Tiny
SATURNTECH9
  • EXPERT
You too keep me posted and we will figure this out.
Was this
answer
helpful?
Yes
No
Sunday, March 27th, 2011 AT 9:31 PM
Tiny
JAYNEMEALS
  • MEMBER
Fuse was fine, battery has a sticker on it showing it less than 6 months old. Cables appear fine too. Will try to 'jump-it' late tonight and see what happens. Will let you know.
Was this
answer
helpful?
Yes
No
Sunday, March 27th, 2011 AT 9:56 PM
Tiny
SATURNTECH9
  • EXPERT
Alright but just because the battery is only 6 month's old doesn't mean it's good.I have gotten brand new batteries that were bad.I'm thinking possible a bad starter but I would just make sure the battery and cables are good. Let me know what you find.
Was this
answer
helpful?
Yes
No
Sunday, March 27th, 2011 AT 10:08 PM

Please login or register to post a reply.

Recommended Guides