1999 Blazer won't start sometimes

Tiny
WFORD16
  • MEMBER
  • 1999 CHEVROLET BLAZER
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 174,567 MILES
We have a 1999 Chevrolet S10 Blazer 4 wheel drive with the Vortech 6 cyc engine 4.3 liter. Our problems started when we had a friend change the plugs on it about a year ago. Shortly after that, the vehicle was mostly hard to start first thing in the morning, but after starting it would start right up the remainder of the day. This happended especially if it was rainy. We first replaced the fuel filter which had no effect. We then towed to mechanic who replaced the fuel pump (twice). The first time it started and ran fine for couple of weeks, then had to be towed to mechanic again. This time it has been a couple of months. The vehicle continues to be very unreliable about starting. This last time we had mechanic come to home instead of towing and he replaced distributor cap and wire and rotor and it started right up! However, after a couple of days. Again, sometimes it starts and sometimes not. Just never know. Do you have any idea what we or the mechanic (who is apparantly stumped) could check to see what replacement is needed.
Do you
have the same problem?
Yes
No
Saturday, July 2nd, 2011 AT 4:20 AM

3 Replies

Tiny
RASMATAZ
  • MEMBER
http://www.2carpros.com/articles/car-cranks-but-wont-start

Next time it refuses to start don't wait for it to make up its mind-do below immediately to determine if its fuel or spark problem

Get a helper disconnect a sparkplug wire or 2 and ground it to the engine atleast 3/16 away from ground-have helper crank engine over-do you have a snapping blue spark? If so-you have a fuel related problem, Do you hear the fuel pump come On when you turn key on? If not check fuel pump fuse and fuel pump relay if okay-check the fuel pressure to rule out the fuel filter/fuel pump/pressure regulator and listen to the injector/s are they pulsing or hook up a noid light. No snapping blue spark continue to troubleshoot the ignition system-power input to the coil/coil packs,coil's resistances,cap and rotor,distributor pick-up coil, ignition control module, cam and crank sensors and computer Note: If it doesn't apply disregard it and keep testing
Was this
answer
helpful?
Yes
No
Saturday, July 2nd, 2011 AT 4:28 AM
Tiny
WFORD16
  • MEMBER
Sure give it another try in morning. Appreciate input alot. Also got a 2000 Dodge Dakota pickup v8 engine with a whine in rearend unless u let off gas. New rear-end? Is that something a shade-tree could do or need dealership? Also keeps heating up but not losing much radiator fluid from anywhere. Overflow blows out a little when it's hot but other than that nothing. Thermostat? The kid drove home since he was only half a mile from house. It was losing power and ticking when he pulled in drive in cloud of steam! Big problem you think?
Was this
answer
helpful?
Yes
No
Saturday, July 2nd, 2011 AT 6:08 AM
Tiny
RASMATAZ
  • MEMBER
Try replacing the Stat for heating problem and follow thru what I've suggested earlier
Was this
answer
helpful?
Yes
No
Saturday, July 2nd, 2011 AT 9:15 AM

Please login or register to post a reply.

Recommended Guides