RUNNING AND IDLING ROUGH

1998 Ford Ranger

Tiny

nerrad1010

June, 29, 2013 AT 10:00 PM

A few months ago if I didnt warm up my truck for approx 10 minutes it would die at stop light/sign. Had always been able to just start it up and go. Once warmed up it ran fine as always. Went on for 2 weeks or so before CEL came on. Replaced IAC, oxygen sensors, fuel filter, injectors cleaned but did not fix problem. Then changed the engine coolant temp sensor and sender and CEL went off and problem solved. Fast forward 2 months to last week at stop light/sign truck running rough, like its missing, a little bit of shakin' going on. But luckily isn't dying nor feeling like its about to die. On the freeway you can feel in the pedal that engine isnt running right. No CEL on. Yet. Any suggestions to what the problem can be?The place I take it to for gen. Maint. Says its not due for a tune up.I was about to clean the throttle body but a sticker on there says DO NOT clean it due to the coating. Its a 2.5 ltr 4 cyl automatic.

FOUND 4561 RELATED QUESTIONS

Running Rough

27 ANSWERS
34 IMAGES

Idles Rough/changed Ects

37 ANSWERS
3 IMAGES

1 Answer

Tiny

ASEMaster6371

June, 30, 2013 AT 7:09 AM

I would look at plugs, wires and coil at this point. A compression test would be advised as well.

Roy

Please login or register to post a reply.

Read Codes Like a Pro
 Step by Step video GMC Yukon XL 2000-2006
Code Read Retrieval/Clear Mercedes-Benz C230
Code Read Retrieval/Clear Chevrolet Camaro
Code Read Retrieval/Clear