POPPING SOUNDS AND HESITATES TO ACCELERATE ?

1997 Mazda MPV

Tiny

redchild_1

September, 14, 2012 AT 9:00 AM

I have a 97 Mazda MPV, I had repairs done on the car which included replacing the muffler, Heated Oxygen Sensor (Bank 1 Sensor 1 H02S-11), the Radiator was replaced, and last Valve Cover Gasket from an oil leak which was the last thing I had done and about a week after the valve cover replaced the car was not acting normally, when I would start the car it would crank up then put off, the putting sounded like it was coming from the exhaust and under the car, this went on for about a month but the car drove fine after it started, that's not giving me so much trouble anymore, but the car is now acting like it doesn't want to accelerate when I take off, when I give it gas it putts and makes popping sounds and hesitates to accelerate and then all of a sudden it will pick up speed until I stop the car and accelerate again, and the check engine light is back on with the same code I already had fixed P1170, can you please help me decipher what my problem is, I feel I paid way to much to get my car fixed and its worse then it was before I had it repaired. Thanks alot Tracy

FOUND 2911 RELATED QUESTIONS

1 Answer

Tiny

ASEMaster6371

September, 14, 2012 AT 10:07 AM

The repairs you had done dont have anything to do with this issue. It sounds like plugs, wires or coil. You need these tested to confirm.

Roy

Please login or register to post a reply.

Vacuum Leak Test and Repair - All Cars
Mass Air Flow Sensor Clean Ford Explorer 1995
Mass Air Flow Sensor Clean Toyota Tacoma