THE TEMP GUAGE ON DASH DOES NOT WORKIS THIS FROM...

1997 Ford Ranger

Tiny

mikehaycock

November, 17, 2012 AT 4:13 PM

The temp guage on dash does not work, is this from the ect or iat. Where is the ect?Would this cause pinging going up hill, I use premium gas w octane booster pinging wont go away

FOUND 509 RELATED QUESTIONS

3 Answers

Tiny

hmac300

November, 17, 2012 AT 4:50 PM

No the pinging isn'tfrom using premium gas or booster, it can be from to much carbon on piston raising the compression to a bad ect to a lot of things. Attached you'll find apic of ectlocationfor a 2.3L as you didnt' give engine size. The gauge could be bad though you have two ect's one for the gauge and one fo the pcm. On the ect gauge one groudn the woire and see if gauage goes up if it does then teh sender is bad if not it'sthe gague maybe

Tiny

mikehaycock

November, 17, 2012 AT 8:02 PM

Question restated, also, I use the booster to prevent pinging-it is a 2.3-the service engine soon light will not illuminate-ive changed out the bulb -and no input data from the test port-basicly is it ok to let the engine ping up hill 10 miles a day -i travel to mtn. Pass ca 5 days wk

Tiny

hmac300

November, 17, 2012 AT 8:25 PM

Try replacing yoru kock sensor
check your connection at the aldl and fuses underhood maybe the mil light will come on then.

Please login or register to post a reply.

Seat Switch Replacement GMC Yukon
Cabin Air Filter Replacement
Open Hood Video
Cabin Air Filter Replacement
Window Regulator and Motor Replacement Honda