1997 Mustang gt ebrake light is on

Tiny
JESUSARENA1997
  • MEMBER
  • 1997 FORD MUSTANG
  • V8
  • 2WD
  • AUTOMATIC
  • 70,000 MILES
I have a 1997 mustang gt with 70,000 miles on it and recentey I noticed that the ebrake light stays on at all times and the handle feels loose, how can I adjust this or fix it, I checked the fluid and its ok. Also wen I turn on the ac or heater on air only comes out the windshield vent and even if I switch the **** to a differen vent it will only come out the windshield. Last question I have an optima battery on it my battery light is on I charged it at home wit a charger for batterys put it on this am and battery meter still reads low cars starts and stays on for a few minutes then dies.
Do you
have the same problem?
Yes
No
Monday, December 27th, 2010 AT 8:17 PM

4 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
The air flow issue is vacuum related. Check under the dash for vacuum leaks. As far as the park brake light, based on your description, it sounds like the brake isn't connected. Is it working at all?
Was this
answer
helpful?
Yes
No
Monday, December 27th, 2010 AT 9:00 PM
Tiny
JESUSARENA1997
  • MEMBER
No its not working at all I whent down a hill and lifted the handle and it didn't work at all. And for the vaccume lines do I need to remove my dashboard for that? And the only time the air comes out of the vent is wen I put the **** on the windshield and wen I set the other **** to fuspeed if I set the **** for air to come out slow it doesn't work at all the **** has to be all tuned to full speed and to windshield mode for me to get anykind ofair coming out? Also what about my question for the battery light.
Was this
answer
helpful?
Yes
No
Monday, December 27th, 2010 AT 9:17 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Okay. I have to ask a couple more questions. First, when the heat doesn't work, do you mean the fan isn't turning on until it is on high? As far as the battery, after the engine dies, is the battery dead again? And finally, have you checked to make sure the parking brake cables are still attached under the vehicle and not broken?

As far as the air flow issue, you shouldn't need to remove the dash. Check under it. There may be a couple thin panels that can be easily removed to access under the dash. At that point, you will be able to trace the hoses. NOTE: If you are lucky, with the engine on, you may actually hear a hissing sound where the leak is located.

Let me know what you find.

Joe
Was this
answer
helpful?
Yes
No
Tuesday, December 28th, 2010 AT 2:05 AM
Tiny
JESUSARENA1997
  • MEMBER
Yea that's what I meant to say the fan wont turn on unless its on high the heat and ac work fine. And as far as the vacume lines I will be checking on that and getting back to you. And for the battery when the engine dies the battery dies to I put it back on the charger and it read that it as low so I just took it to an auto parts to get it charged see if that works better than my charger. My bro who is a tech but is in the army at the moment told me that it can also be the alternator or I might just need a new battery, tomorrow when I pick it up and put it on ill see wat happens, because even when I charged it my self the battery light was on after putting it back on fully charged. I will also be checking for the parking brake cables I havent tought about that. Im just not sure if I do need the alternator or just the battery.
Was this
answer
helpful?
Yes
No
Tuesday, December 28th, 2010 AT 2:56 AM

Please login or register to post a reply.

Recommended Guides