1996 GMC V6 Standard misfiring

Tiny
BR213
  • MEMBER
  • 1996 GMC SIERRA
  • 6 CYL
  • 4WD
  • MANUAL
  • 124,000 MILES
1996 GMC Vortec V6, 4x4 stand sierra xcab, my problem is @ approx 16-1800 rpm after truck as warmed up, or upon the first opening of the thermastat, I get skipping, if only light pressure on accellerator. If I step on it it clears up, but will reappear when accelerator pedal is eased up on, about the time when the "shift up" indicator comes on. More pronounced when raining or damp, and once in 5th gear rarely, but occationaly will run a little rough, but mainly in 1-4 gears and appears to be about the same time the "shift up" light appears. This truck was like this when I bought it over a year ago, I have changed plugs and wires, and recheck wires. At first it would give a check engine light that would usually go out in a day or two, however I haven't had a check engine light for about 4 or 5 months. I did have it scanned at one point when engine light came on, and it gave a code for misfire on #2 cyl. I know of a few sensors, ie MAPP, throttle possitioning, and I believe one or two more. Was looking to see if you had and "experienced educated" guess on where to start as these sensors can get into $$ and labor to install them.
Do you
have the same problem?
Yes
No
Sunday, February 13th, 2011 AT 12:20 AM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Have you checked plugs and wires?
Was this
answer
helpful?
Yes
No
Thursday, March 10th, 2011 AT 4:23 PM

Please login or register to post a reply.

Recommended Guides