1995 Volvo 940 Turbo Stalls In Reverse, Hesitation

Tiny
LDUNBAR
  • MEMBER
  • 1995 VOLVO 940
  • 2.3L
  • 4 CYL
  • TURBO
  • RWD
  • AUTOMATIC
Hello, Everyone,

I have my 1995 Volvo 940 Turbo that stalls in reverse and hesitates on take off. The following is a breakdown of what has been done so far:



1. Initial Issue from March to October is hard starts; it would take 15 minutes or more to start car; it would be longer sometimes in cold weather.

2. Car would have erratic idle after startup; car reaches operating temperature before movement; car would bog down in idle and die only in reverse; initial acceleration from takeoff is slow;

car runs fine once out of first gear from takeoff; car bogs down on braking with idle lowering; sometimes car stalls at braking; gas is sometimes tapped slightly to stop stalling.

3. Issue of hard start would be intermittent; it would be less prominent in hot weather and more prominent in cold weather.

4. Sometimes in rain or wet weather, car would stall and sometimes backfire; Distributor Cap is normally changed.

5. By October, a no-start condition occurs.

6. Car starts now, idle is not erratic; car would bog down in idle and die only in reverse; you barely tap gas to keep from dying in reverse; initial acceleration from takeoff is slow; car

putts a litte; car runs fine once out of first gear from takeoff; exhaust flows strongly; takeoff slightly improves incrementally with continued operation; car bogs down on braking with idle

lowering; sometimes car stalls at braking; gas is sometimes tapped slightly to stop stalling.

7. During idle or operation, sometimes coolant will boil in reservoir; toggle fan brings temp down to normal in between fan cycles; toggle fan keeps coolant temp normal in really hot weather.



The following parts have been changed and are still prominently new:


Ignition Coil

Spark Plug Wires

Spark Plugs

Distributor Cap (Intially Sealed With Sealant, Condensation Issue When Raining Causes Stalling)

Rotor Button

Condensation Cap For Distributor Cap (No Need For Sealant Now)


K&N Air Filter


Turbo Intake Hose (Original Had Disentegration In Spots)

Exhaust Manifold Gasket (With New Locking Nuts and Sealant On Manifold Side, Not Block Side)

Power Stage (Ignition Module or Ignition Stage Amplifier)

Engine Coolant Temperature Sensor

Gauge Temperature Sensor

Knock Sensor

All Vacuum Hoses

All Coolant Hoses (Including Oil Cooler Hoses)

Fuel Pressure Regulator

Oxygen Sensor

Catalytic Converter (Honeycomb In Original Rattles, Discovered Gone When Removed)

Exhaust Resonator/Central Muffler (Original Damaged By Honeycomb, Sounded Like Broken Glass, Baffles More Than Likely Clogged)

Idle Air Control Valve

Starter Solenoid (Starter Tested Good)

Power Brake Booster (Original Replaced, Failed 2 Out Of Three Brake Pedal/Vacuum Tests)

Battery

Radio Suppression Relay

Throttle Position Sensor

Fuel Filter

Timing Belt and Tensioner


Crankshaft Position Sensor (Last In Chain, Resolved No-Start For Now)



The following are checkpoints, mods, and maintenance:

1. Modded Airbox for more airflow, no codes present from OBD before or after

2. Cleaned MAF Sensor with MAF Sensor Cleaner, no codes present from OBD before or after

3. Checked EGR Valve - Diaphram not broken, free movement, appears functioning

4. Had EGR Pipe Rewelded - Pipe broke from connection to throttle body, completely sealed and functional, Minimal Carbon Removed

5. No codes from EGR temp sensor before or after

6. Checked EGR Vacuum Controller through OBD - appears functional

7. Checked Fuel Pump - Repaired frayed hot wire, sealed, pump fully functioning

8. Checked Fuel Pump Relay - Functioning

9. Properly adjusted Idle Air Speed - Steady Between 700-800 RPM

10. Checked EGR Pipe to Exhaust Manifold - Minimal Carbon Removed

11. Cleaned Throttle Body with Throttle Body Cleaner - No Soot/Carbon exiting system

12. Created Toggle with Fuse in between connection, connected to slot in fuse box, cuts off with car, slight battery drain issue before and after installation

13. Checked oil in case - oil change still new, no milky appearance suggested head issues

14. Removed and cleaned breather box - no oil deposits clogging operation

15. Checked charcoal canister - stalling in reverse happens with and without it connected

16. Checked muffler during disassembly of exhaust system - no honeycomb/debris present during testing

17. Car is at Top Dead Center - Timing

18. Fuel Injectors tested fine with OBD and Pressure present at rail



The following parts have not been changed yet:

Charcoal Box

MAF Sensor (No Codes)

EGR (No Codes)

EGR Vac Controller (No Codes)

Compressor (No A/C, issue with stalling is unrelated)

Power Steering Pump (Slight squeaking on rotation, PB Blaster in bearing area confirms, issue with stalling unrelated)





Other Issues


Slight battery drain coming from somewhere in the car, have to remove negative from battery for now


Any suggestions are greatly appreciated. Thanks!
Do you
have the same problem?
Yes
No
Friday, May 29th, 2015 AT 4:26 AM

1 Reply

Tiny
DOCFIXIT
  • EXPERT
Hi
One question what is fuel pressure?
Was this
answer
helpful?
Yes
No
Friday, May 29th, 2015 AT 8:34 AM

Please login or register to post a reply.

Recommended Guides