MY CAR WONT GO INTO REVERSE.

  • Tiny
  • Chanaenae
  • 1995 DODGE AVENGER
  • 260,000 MILES

When I put my avenger into reverse, it feels like it shifts into it, im pretty sure, but it'll only rev it when I press the gas to back up and some smoke wiul come out. Ive had the tranny looked at. Apparntly the computer was soaked in oil for the tranny and there was leak with the tranny fluid that was fixed. Is there anything I can do? Im only 21 and being a female, ive gotten caught in some situations before.

Do you
have the same problem?
Yes
No
Tuesday, September 11th, 2012 AT 9:24 PM

7 Replies

  • Tiny
  • Saturntech9
  • EXPERT
  • 30,228 POSTS

So the fluid is full and what color is the fluid?Probably going to have to do a pressure test on the transmission to see what the pressure is.

Was this
answer
helpful?
Yes
No
Tuesday, September 11th, 2012 AT 9:40 PM
  • Tiny
  • Chanaenae
  • MEMBER

Im not sure what color the fluid is I had my father do it for me, he said it looked how it should and the fluid was fine. Is there a possibility I need a new tranny? Or will it be an ohk fix?

Was this
answer
helpful?
Yes
No
Tuesday, September 11th, 2012 AT 10:22 PM
  • Tiny
  • Saturntech9
  • EXPERT
  • 30,228 POSTS

Depends what's wrong with it could a pressure issue that doesn't require tear down. Or it could need to be rebuilt. Is yoyr check engine lighy on?

Was this
answer
helpful?
Yes
No
Tuesday, September 11th, 2012 AT 10:28 PM
  • Tiny
  • Chanaenae
  • MEMBER

Yes it is, but my father said something about it being the co2 sensor making the check engine light or something like that?

Was this
answer
helpful?
Yes
No
Tuesday, September 11th, 2012 AT 10:36 PM
  • Tiny
  • Saturntech9
  • EXPERT
  • 30,228 POSTS

O2 sensor that has nothing to do with your transmission.

Was this
answer
helpful?
Yes
No
Wednesday, September 12th, 2012 AT 12:22 AM
  • Tiny
  • Chanaenae
  • MEMBER

Ya but he said that that is the reason the check engine light is on, that its not the transmission putting the light on so I dont think the light has anything to do with my reverse not working? But of course if I knew my stuff I wouldnt be here :P

Was this
answer
helpful?
Yes
No
Wednesday, September 12th, 2012 AT 12:27 AM
  • Tiny
  • Saturntech9
  • EXPERT
  • 30,228 POSTS

That's what I just said the o2 sensor has nothing to do with the transmission.I would do a pressure test on the transmission first step. But before that make sure the fluid is full.

Was this
answer
helpful?
Yes
No
Wednesday, September 12th, 2012 AT 3:37 PM

Please login or register to post a reply.

Other Transmission Gear Reverse Questions