I have a 95 lesbare Custom and iM having issues.

Tiny
EDWARDJOSEPHSON
  • MEMBER
  • 1995 BUICK LESABRE
  • 129,000 MILES
I have a 95 lesbare custom and im having issues with it starting consistantly, as well as staying running once it does start. I took it somewhere and the replaced the crank sensor, but that didnt fix the problem. When it stalls, it feels like the fuel is being shut off. I replaced the fuel pump relay, but im still having the same problem. Any thoughts would be greatly appreciated.
Do you
have the same problem?
Yes
No
Tuesday, February 26th, 2013 AT 4:15 PM

12 Replies

Tiny
DOCFIXIT
  • EXPERT
Has PCM been checked for codes? Check engine light on? Has fuel pressure been tested? Recent repairs?
Was this
answer
helpful?
Yes
No
Tuesday, February 26th, 2013 AT 4:47 PM
Tiny
EDWARDJOSEPHSON
  • MEMBER
The fuel pressure has been tested but I dont always hear the pump turn on when I turn the key. None of the lights are on unless the car stalls. When it stalls the oil, battery, and engine lights come on but when its running theres no lights on. The only thing ive done recently other than what I stated in my question is my front wheel bearings and the water pump and gasket.
Was this
answer
helpful?
Yes
No
Tuesday, February 26th, 2013 AT 5:07 PM
Tiny
DOCFIXIT
  • EXPERT
Important has PCM been coded? Fuel pressure needs to be tested
Was this
answer
helpful?
Yes
No
Tuesday, February 26th, 2013 AT 5:21 PM
Tiny
EDWARDJOSEPHSON
  • MEMBER
When I first took it to be looked at they tested the fuel pressure and it passed. Im not sure if they coded the PCM
Was this
answer
helpful?
Yes
No
Tuesday, February 26th, 2013 AT 5:22 PM
Tiny
DOCFIXIT
  • EXPERT
O.K. Go to an AutoZone or similar have them check for codes if any post will advise. Was IAC looked at when at shop? Why was crank sensor replaced?
Was this
answer
helpful?
Yes
No
Tuesday, February 26th, 2013 AT 5:27 PM
Tiny
EDWARDJOSEPHSON
  • MEMBER
Will an AutoZone be able to read obd1? They said the crank sensor was pertty worn and could have been the problem. Im not sure what IAC stands for so I cant really answer that lol.
Was this
answer
helpful?
Yes
No
Tuesday, February 26th, 2013 AT 5:39 PM
Tiny
EDWARDJOSEPHSON
  • MEMBER
I dont know if they checked the IAC. They did try replacing the mass air flow sensor but that did nothing as well.
Was this
answer
helpful?
Yes
No
Tuesday, February 26th, 2013 AT 5:50 PM
Tiny
DOCFIXIT
  • EXPERT
IAC idle air controler if faulty can cause hard start and stalling
Car is equiped with ODB11 has 16 pin connector GM sswitched over in 95
Was this
answer
helpful?
Yes
No
Tuesday, February 26th, 2013 AT 5:52 PM
Tiny
EDWARDJOSEPHSON
  • MEMBER
Would it also cause it to die out while driving? Its shut down on me several times on the highway as well as stalling from idle.
Was this
answer
helpful?
Yes
No
Tuesday, February 26th, 2013 AT 6:08 PM
Tiny
DOCFIXIT
  • EXPERT
IAC would not cause shut down at speed Need PCM checked for codes may have faulty PCM shuting down fuel pump
Was this
answer
helpful?
Yes
No
Tuesday, February 26th, 2013 AT 6:20 PM
Tiny
EDWARDJOSEPHSON
  • MEMBER
Okay ill have to get it checked. Im hoping the pcm is fine ive had to change that within the last couple years as well but this issue is recent. Will post with results for further thoughts if needed.
Was this
answer
helpful?
Yes
No
Tuesday, February 26th, 2013 AT 8:01 PM
Tiny
DOCFIXIT
  • EXPERT
O.K.
Was this
answer
helpful?
Yes
No
Tuesday, February 26th, 2013 AT 8:31 PM

Please login or register to post a reply.

Recommended Guides