DO THE FUEL INJECTOR CONECTOR TERNIMALS HAVE VOLTAGE TO BOTH SIDES

Tiny
ELMO70
  • MEMBER
  • 1990 FORD F-150
  • 137,000 MILES
MY 1990 F150 302 HAS A FUEL PROBLEM, IT WILL RUN IF I BYPASS THE INJECTORS AND PUT FUEL INTO THROTTLE BODY IT WILL RUN TILL IT IS GONE, I TOOK THE CONECTOR OFF ONE INJECTOR TO CHECK VOLTAGE WITH A PROBE TEST LIGHT, I GROUNDED THE BLACK LEAD TO CHASSIS AND PROBED EACH TERMINAL WITH IGNITION SWITCH ON ONE AT A TIME BOTH SIDES LIT UP. FUEL PRESSURE AT FUELRAIL IS GOOD I DON'T KNOW WHAT TO DO NEXT PLEASE SOMONE HELP ME
Do you
have the same problem?
Yes
No
Sunday, September 18th, 2011 AT 2:12 AM

7 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
When you checked for power, did the light flash on and off? Did you check the amount of voltage they are getting?
Was this
answer
helpful?
Yes
No
+1
Sunday, September 18th, 2011 AT 2:13 AM
Tiny
ELMO70
  • MEMBER
NO I DIDN'T TURN THE ENGINE OVER AND I DIDN'T CHECK HOW MUCH VOLTAGE THERE WAS BUT THE TEST LITE WAS BRIGHT ON BOTH SIDES
Was this
answer
helpful?
Yes
No
-1
Sunday, September 18th, 2011 AT 3:30 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Turn the engine over to see if the light flashes. You may be getting constant power. If there was power without cranking, the injectors are staying open. Could be a PCM issue.
Was this
answer
helpful?
Yes
No
Sunday, September 18th, 2011 AT 4:20 AM
Tiny
ELMO70
  • MEMBER
I TOOK THE CONTECTORS OFF 5 OF THE INJECTORS ALL I CAN GET TO EASY, TESTED WITH TEST BULB ALL HAD POWER BOTH SIDES OF CONT. TURNED ENGINE OVER LIGHT DID NOT FLASH OFF AND ON IT JUST STAYED ON. I CHECKED VOLTAGE 11.98 ON ALL OF THEM.
Was this
answer
helpful?
Yes
No
+1
Monday, September 19th, 2011 AT 1:33 AM
Tiny
WRENCHTECH
  • EXPERT
Let me jump in to point out one thing here, the reason you are seeing power on both sides. These injectors are wired to fire in sets of 3 (2, 3&6) and ( 1, 4&5) so if any of the 3 injectors are plugged in at the time you are testing for power, you will be reading power through the injector that is still plugged in. You need to have all of them disconnected in that gang to not see power on the trigger side.
Was this
answer
helpful?
Yes
No
Monday, September 19th, 2011 AT 1:47 AM
Tiny
ELMO70
  • MEMBER
I TOOK ALL 8 CONNECTORS OFF INJECTORS ONLY ONE SIDE HAS POWER WITH SWITCH ON I TOOK THE LEAD OF TEST LITE AND PUT ON POS. SIDE OF BATTERY, PROBED THE SIDE OF CONNECTOR THAT DIDN'T LITE UP CRANKED ENGINE OVER IHAD REAL DIM FLASH ON AND OFF. THESE CONNECTORS HAS RED WIRE ONE SIDE ALL 8 CONNECTORS THE OTHER SIDE HAS 4 TAN AND 4 WHITE THE TAN WIRES GO TO PCM INJ. BANK #1 WHITE GOES TO PCM INJ. BANK #2 SHOULD VOLTAGE BE LESS ON TRIGGER SIDE OF CONNECTOR?
Was this
answer
helpful?
Yes
No
+1
Tuesday, September 20th, 2011 AT 4:38 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Either the PCM is bad or the wiring has broken down. It doesn't sound like there is enough power too fire the injectors.
Was this
answer
helpful?
Yes
No
+2
Tuesday, September 20th, 2011 AT 4:54 AM

Please login or register to post a reply.

Recommended Guides