While driving my truck cuts off

Tiny
JOHNNYROCKET
  • MEMBER
  • 1988 FORD F-150
  • 250,000 MILES
It idles rough but has for years, lately while driving it randomly cuts out, dies. I have to put it into neutral and restart it then back into drive. Sometimes it will do it again sometimes not. Seems electrical or maybe fuel. But it idles fine. When I first start it in the am it idels good for 10 or so seconds then stalls, I restart it sometimes it'll do it a second time then its fine. It also idles rough but never stalled/cut out while driving before this week. It is a 302 5.0 L EFI. I put a can of throttle body cleaner in the dual butterflys, then put a can of seafoam in gas tank to see if that was it. Then I replaced the fuel filterafter doing that it ran just fine around the neighborhood. Later that day it started stalling/cutting out again. So I replaced the cap, rotor, plugs and wires. This did not solve the problem. The low pressure pump in the tank has been replaced last year. Could it be the high pressure fuel pump, fuel pressure regulator on the rail, or some other fuel component. Im not sure about it being a fuel problem because while idling in the driveway I can hit the acclerator and it rev's just fine no cutting out but it backfires when you suddenly let off the gas peddle.
Do you
have the same problem?
Yes
No
Sunday, September 25th, 2011 AT 2:39 PM

8 Replies

Tiny
RASMATAZ
  • MEMBER
Verify the fuel pressure if its within specs-start here
Was this
answer
helpful?
Yes
No
+3
Sunday, September 25th, 2011 AT 2:42 PM
Tiny
JOHNNYROCKET
  • MEMBER
Do you think it could be fuel related since it does not do it while ideling in park only while driving and trying to accelerate.
Was this
answer
helpful?
Yes
No
+1
Sunday, September 25th, 2011 AT 3:04 PM
Tiny
RASMATAZ
  • MEMBER
Check the fuel pressure-start here and give us the readings
Was this
answer
helpful?
Yes
No
-1
Sunday, September 25th, 2011 AT 3:08 PM
Tiny
MOUNTAINSIDEGROVE
  • MEMBER
I have the same problem with my truck it's a 89' F150 with the 5.0 engine. It will either want to cut off or cut off while driving but it idles fine. It has a pattern to it. It starts out only doing it every couple times you drive the truck then work up to all the time you drive it. The all at one it will just not start again. I will crack and get it started, then shuts off as soon as I put it in drive and tap the gas. I know it's fuel related. I have replaced the fuel filter. And every time it acts or does shut off I get this bad gas smell. Please any one with and idea?
Was this
answer
helpful?
Yes
No
Thursday, September 29th, 2011 AT 9:26 PM
Tiny
RIVERMIKERAT
  • MEMBER
Johnnyrocket and mountainsidegrove, did you check the fuel pressure at the regulator yet? Cold and fully warmed up?
Was this
answer
helpful?
Yes
No
-1
Monday, October 3rd, 2011 AT 3:52 AM
Tiny
MOUNTAINSIDEGROVE
  • MEMBER
How do you go about checking the fuel pressure?
Was this
answer
helpful?
Yes
No
Monday, October 3rd, 2011 AT 10:38 PM
Tiny
JOHNNYROCKET
  • MEMBER
I meant to purchase a fuel pressure tester this weekend but my battery died so I had to get a new one first. As soon as the weather clears up ill try to get one and get back to u. Thanks
Was this
answer
helpful?
Yes
No
Monday, October 3rd, 2011 AT 10:52 PM
Tiny
RIVERMIKERAT
  • MEMBER
You should be able to borrow or rent one from stores such as Autozone and Pep Boys.
Was this
answer
helpful?
Yes
No
Wednesday, October 5th, 2011 AT 3:36 AM

Please login or register to post a reply.

Recommended Guides