86 NO SPARK.

1986 Ford Ranger

Tiny

mike luckey

February, 2, 2014 AT 9:31 AM

86 ford ranger, died while driving. Replaced the fuel pump and relay. Then later realized that the pump had no power to it. Also discovered a no spark situation. So, no spark, and no power to the fuel pump. ICM and coil test ok. Put in a new ignition switch. Removed EEC computer, to go to pullnsave to find another. Out of desperation, I tried without the computer installed. LOTS of spark, but still no power to the fuel pump. Weird. Couldn't find a used EEC, buy suspect this may be the problem. Any Ideas? BTW. Also checked the inertia switch. Everything ok there too. Help!

FOUND 2774 RELATED QUESTIONS

6 Answers

Tiny

hmac300

February, 2, 2014 AT 9:43 AM

There is a fusible link running probably off the starter relay it is a yellow wire leading to fp relay the fusible link is blue and are available at auto parts. Make sure to put correct one in.

Tiny

mike luckey

February, 2, 2014 AT 2:30 PM

I will check that thank you! Do you think my spark issue could be a bad computer?

Tiny

hmac300

February, 2, 2014 AT 3:42 PM

It could be but scan for codes to see if any sensors are bad like a crank sensor or cam sensor.

Tiny

mike luckey

February, 3, 2014 AT 5:37 PM

No codes, fusible links ok. Still leaning toward the EEC. What do ya think?

Tiny

hmac300

February, 4, 2014 AT 5:52 AM

Try it is all I can say

Tiny

mike luckey

February, 5, 2014 AT 1:26 PM

Kind of stuck trying with that now. I think we have tested/tried everything else. I will let you know.

Please login or register to post a reply.

Ignition System Test Guide
Ignition Coil System Test Repair - All Cars
Crank Angle Sensor Replacement Mercedes Benz
Crankshaft Position Sensor Replace Chevrolet