Chevy temp gauge

Tiny
JGAYTHWAITE
  • 1974 CHEVROLET TRUCK
  • 67,000 MILES

I have a 1974 stepside chevy I just bought with a fresh rebuild on a 350, and my temp gauge isn't working, any ideas on how to troubleshoot the issues,
Thanks

Do you
have the same problem?
Yes
No
Monday, June 13th, 2011 AT 4:54 PM

3 Replies

Tiny
JDL
  • EXPERT
  • 16,308 POSTS

Take the wire connector loose from the temp sending unit on the engine. Key on, any voltage on that wire? Usually the sending unit controls resistance to ground. If you touch that one wire to ground, key on, the gage should move, don't peg it or use a resistor.

I haven't found a wiring diagram on that, yet. Not sure of sending unit location?

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Monday, June 13th, 2011 AT 5:03 PM
Tiny
JGAYTHWAITE
  • MEMBER

If the gauge does move, what would need replaced? The sending unit? And if it doesn't move would the gauge need replaced?

Was this
answer
helpful?
Yes
No
Monday, June 13th, 2011 AT 5:15 PM
Tiny
HMAC300
  • EXPERT
  • 47,000 POSTS

See if you have a flashing light at the sender. Use a test light for this. If you do then your sender isn't correct or it has silicone on the threads and not letting it complete the circuit.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Monday, June 13th, 2011 AT 11:48 PM

Please login or register to post a reply.

Related Instrument Cluster Gauge Engine Temperature Test Questions

Help us by donating