Mechanics

IDLE PROBLEM

Toyota Camry

'92 Camry, 3.0 V-6, automatic, 115k, recent tune (plugs, cap, rotor, pcv vlv.)
Car idles and runs fine when cold, but when at operating temp. And coming to a stop the idle rpms fall and the engine will nearly die, then recover and idle ok until the next stop. It occasionally dies and restarts ok. This happens while car is in drive gear. If I put it in neutral when stopping, idle remains ok. A scan revealed only a Vehicle Speed Sensor code set. I checked, cleaned the EGR and it opens and closes with a good snap with vacuum applied, but don't know about the EGR modulator function or possible IAC problem, too. Can VSS affect idle, etc. Or?
Thanks
Avatar
Bentwrench
September 23, 2007.



See if there is a switch over valve to egr, follow vaccum line, or disconnect egr and plug vaccum line.
What does this do?

Tiny
Buzzsaw
Sep 25, 2007.
See if there is a switch over valve to egr, follow vaccum line, or disconnect egr and plug vaccum line.
What does this do?[/Quote: a7f344202f]

Thanks, this is elderly folks car, I will pursue your suggestions when I have access to the car again.

Tiny
Bentwrench
Sep 25, 2007.
2002 Toyota Camry 107,000 miles. Bought a new battery today and now when I start the car it shuts off. The lights and everything will come on in the car and it does start but it will either shut right off unless you keep your foot on the gas or it will run for a minute and then shut off the idle is right above 0. I had it checked for codes and nothing came up. My CEL is not on, the tank is full & I had a tune up last month. I think it could be because the car is idiling low--too low. The starter and alternator is also fine. I didnt have this problem until I replaced the battery this afternoon, everything was fine. Please help. I don't know what else to do.

Tiny
Lilbitohoney
Oct 14, 2007.
Maybe it needs an idle relearn or just remove the IACV and clean it and retry.

Rasmataz
Oct 15, 2007.